IBM Support

A blank page is displayed for some users who connect to Planning Analytics Workspace (duplicate user issue)

Troubleshooting


Problem

In Planning Analytics Workspace, some of the existing users are now getting a blank page just after logging in.

Cause

For reasons that are still unknown, these users have been duplicated in the Workspace databases.

Resolving The Problem

All duplicate users have to be deleted.
- On either Windows Powershell or Linux, run this command to display the list of users:
docker exec wa-proxy node tools/Tools.js
- Search for any identical "LoginId" so that to determine if these users are only duplicated or if they appear more than twice (in that case, the solution below will have to be applied several times)
- create a CSV file that contains these lines (change the dummy user informations by the actual user informations):
Login Id,First Name,Last Name,Role,Email,Status,Directive
JSmith,John,Smith,creator,John.Smith@Domain.Com,ACTIVE,REMOVE
...etc.
- Connect to PAW as an admin

- Go to the "Users" folder
- Find the personal folders of these users and copy them to another safe temporary location.
 
- Go to the Administration page at the top-right

- Select the "Users" tab
- Click the "Upload users" link at the bottom-right
- Go find the CSV file and load it.
==> this should delete one occurrence of the duplicate users (but we do not know which occurrence will be deleted, that is why we saved the personal folders first)
- If some users have more than 2 occurrences, then run this again, until only one occurrence remains.
- Now let these users reconnect.  If this is working, then the final step is just to restore the content of their personal folders.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m50000000KzIzAAK","label":"Planning Analytics Workspace"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
23 December 2020

UID

ibm16339729