IBM Support

AITK and debackend pods crashing

Troubleshooting


Problem

After performing openshift upgrade from version 4.3 to 4.4, debackend and aitk pods are crashing. Checking logs in the ibm-aitk-orchestrator-xxxxxx-xxxxxx container, we found following error:
"name": "celery.redirected", "type": "other", "log": "MasterNotFoundError".

Symptom

Unable to load DE search results.

Cause

This was caused due to redis not restarting properly.
Redeploying redis resolves this issue:
helm delete --purge ibm-redis-default --tls
cd into support folder: ibm-security-foundations-prod/ibm_cloud_pak/pak_extensions/support/runcr.sh redis default
AITK and DE pods will restart itself but encase if manual CR needs to be run, following can be performed:
optional:
ibm-security-foundations-prod/ibm_cloud_pak/pak_extensions/support/runseq.sh aitk
ibm-security-foundations-prod/ibm_cloud_pak/pak_extensions/support/runseq.sh de

Resolving The Problem

This was caused due to redis not restarting properly.
Redeploying redis resolves this issue:
helm delete --purge ibm-redis-default --tls
cd into support folder: ibm-security-foundations-prod/ibm_cloud_pak/pak_extensions/support/runcr.sh redis default
AITK and DE pods will restart itself but encase if manual CR needs to be run, following can be performed:
optional:
ibm-security-foundations-prod/ibm_cloud_pak/pak_extensions/support/runseq.sh aitk
ibm-security-foundations-prod/ibm_cloud_pak/pak_extensions/support/runseq.sh d

Document Location

Worldwide

[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTDPP","label":"IBM Cloud Pak for Security"},"ARM Category":[{"code":"a8m0z0000001h8kAAA","label":"Data Explorer"}],"ARM Case Number":"TS004273156","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
30 September 2020

UID

ibm16339725