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** Troubleshooting ** "File does not begin with '%PDF-'" error when running standard report (to PDF format)

Troubleshooting


Problem

User runs a standard report. User changes the output 'format' to be PDF.
An error appears.

Symptom

The error varies slightly, but be similar to:
image 5913
File does not begin with '%PDF-'

Cause

There are several known causes for similar messages:
Scenarios 1 and 2 apply to earlier versions (before 10.4.2) of IBM Cognos Controller.  Scenarios 3 and 4 apply to 10.4.2 (Embedded Report Library)
  
Scenario #1 - Incompatible settings in Adobe Acrobat/Acrobat Reader X
  • For more details, see separate IBM technote #198889.
Scenario #2 - (RARE / unlikely) the setting "Temporary objects location", triggered by upgrading from an old (unsupported) version of Cognos BI.
  • For more details, see separate IBM technote #510911.
  
Scenario #3 - The system has been configured to (a) use 'ccrReports' and (b) SQL has been restricted to only using 'TLS 1.2'. However, ccrReports has not been configured to use TLS 1.2.
  • For more details, see separate IBM technote #6327349.
Scenario #4 - The client is using Oracle and manual steps are required to complete the configuration of 'Embedded Report Library' for Oracle.
  • For more details, see separate IBM technote #6558972.

Diagnosing The Problem

After, receiving, the generic error image (File does not begin with '%PDF-', open the file mentioned on the error by using a text editor software.  The actual error is recorded on that .pdf file.  Use that error to search for a solution.

Resolving The Problem

Scenario #1
Disable (untick) "Display PDF in browser" in Adobe Acrobat/Acrobat Reader X preferences. 
  • For more details, see separate IBM technote #198889.
 
Scenario #2
Disable (untick) "Display PDF in browser" in Adobe Acrobat/Acrobat Reader X preferences. 
  • For more details, see separate IBM technote #198889.
Scenario #3
Reconfigure IBM Cognos Controller reports service (also known as 'ccrReports') to use TLS 1.2.
  • For more details, see separate IBM technote #6327349.
Scenario #4
Add the appropriate Oracle JDBC driver to indicated locations.
  •  For more details, see separate IBM technote #6558972.

Document Location

Worldwide

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Document Information

Modified date:
24 February 2022

UID

ibm16327347