Troubleshooting
Problem
User navigates to cases application either from home page or from navigation menu and receives "Unable to perform the search operation. Please contact the Resilient administrator and report this issue." message.
Symptom
Unable to use cases, Analytics and other SOAR functionality.
Cause
As part of application pod readiness, elesticsearch is not initialize.
Following error can be observed in oc logs $(oc get pod -l name=isc-cases-application -o=name) -c cases-application-client-log-tailer:
ElasticSearch operation POST on https://ibm-dba-ek-isc-cases-elastic-ibm-dba-ek-client:9200/principals/_doc/_search failed with response 404: no such index.
Resolving The Problem
To get cases to recreate the elastic index and populate it, the following command can be run
oc exec $(oc get pod -l name=isc-cases-application -o=name) -c cases-application -- resutil configset -key elastic_server.init_schema -bvalue true
which flags that a reindex is required. Cases application pod should then be restarted and it'll recreate indexes on startup
oc delete $(oc get pod -l name=isc-cases-application -o=name)
Document Location
Worldwide
[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTDPP","label":"IBM Cloud Pak for Security"},"ARM Category":[{"code":"a8m0z0000001h8pAAA","label":"Cases"}],"ARM Case Number":"TS004099021","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.3.0"}]
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Document Information
Modified date:
27 August 2020
UID
ibm16323675