IBM Support

Guardium v11.0p215 (or later bundle or GPU patch) should be installed BEFORE setting or changing the timezone on a new v11.2 Guardium Appliance or a newly upgraded to v11.0p200 Appliance

Troubleshooting


Problem

Guardium v11.0p215 (or later bundle or GPU patch) should be installed BEFORE setting or changing the timezone on a new v11.2 Guardium Appliance or a newly upgraded to v11.0p200 Appliance
The plain Guardium v11.2 (v11.0p200) had an issue which can affect the operation of the Data Management functions from running from GUI or on a Schedule. Installing the v11.0p215 (or later bundle or GPU patch) before any timezone setting or change is made will prevent the problem.
 
 

Symptom

With v11.2 before the v11.0p215 (or later bundle or GPU patch) is installed the following example error may be seen in some scheduled Data Management jobs .
 
Scheduled job error "dataImportJob trigger: dataIOJobGroup.dataImportJob DataAggJob.execute(): I/O Error during data import dataArchiveJob"   

The problem might affect any Data Management process issued from the GUI or Schedule

Cause

The problem was caused by a timezone issue that can add incorrect entries into an internal catalog entry table used by Guardium.
The incorrect entries stop the Data Management functions from running from the GUI or Schedule.

Environment

The problem arises when using plain v11.2 (v11.0p200) and if the timezone is set or changed BEFORE v11.0p215 or later bundle or GPU patch is installed

Resolving The Problem

This problem was fixed in v11.0p215 available ETA September 2020 and then all later bundle or GPU patches - however they only fix the future catalog entries going forward from the time v11.0p215 (or later bundle or GPU patch) is installed

If any previous catalog entries with incorrect timezone information were made under plain v11.2 (v11.0p200) this fact could still cause a problem.
As such IBM Technical Support have created a script which can be employed to correct the old catalog entries
In this case - please engage the IBM Technical Support if the scripts are needed and reference this technote.
IBM technical Support can issue the script with instructions to employ the fix

IBM Technical Support Engineers
Please review the internal references for this technote which will give directions to employ the fix on a customer system.
Fix Central
All the latest GPU Fixpack Sniffer agent releases can be found on Fix Central

Document Location

Worldwide

[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
09 March 2021

UID

ibm16323589