Troubleshooting
Problem
VIOS_VFC_HOST error in VIOS errlog
Symptom
Looking at the error log
DATA
rc = 0x00000013 <-- decimal 19 which is ENODEV
failure_type = 0x00
fail_reason_code = 0x00
fail_reason_exp = 0x00
einval_arg = 0x00
login->SCSI_ID = 0x00000000001E1900Cause
Review the Detail Data in order to determine the cause.
Environment
PowerVM VIOS 3.1
Diagnosing The Problem
Obtains error log details using
errlog command.$ errlog -ls|tee errlog.out
$ vi errlog.out (to see error details)
LABEL: VIOS_VFC_HOST
IDENTIFIER: 95A6D9B9
Date/Time: Wed Sep 20 19:03:47 2023
Sequence Number: 12001
Machine Id: 00C09BE84C00
Node Id: <VIOS>
Class: S
Type: TEMP
WPAR: Global
Resource Name: <vfchostN>
Description
Virtual FC Host Adapter detected an error
Probable Causes
Virtual FC Host Adapter Driver is an Undefined State
Failure Causes
Virtual FC Host Adapter Driver is an Undefined State
Recommended Actions
Remove Virtual FC Host Adapter Instance, then Configure the same instance
Detail Data
ERNUM
0000 0089 [.... ]
ABSTRACT
fp_ioctl() failed for SCIOLSTART
AREA
File System
BUILD INFO
BLD: 2204 01-10:54:07 x2022_13A5
LOCATION
Filename:npiv_utils.c Function:npiv_port_sciolst Line:5613
DATA
rc = 0x00000013 failure_type = 0x00 fail_reason_code = 0x00
fail_reason_exp = 0x00 einval_arg = 0x00 login->SCSI_ID = 0x00000000001E1900
OS Type = 0x03
The error decodes to
Sep 20 19:03:47 vfchost14 T VIOS_VFC_HOST NPIV_ERR_0089 (PLOGI) failed [dst scsi_id 0x1E1900] npiv_utils.c npiv_port_sciolst 5613 [rc ENODEV [ostype AIX Resolving The Problem
Return code 0x00000013 (ENODEV) means that the client LPAR (AIX in this example) is trying to login to something in the SAN that is no longer there. The storage is reporting that device is not available.
This indicates that the client device driver attempted to connect to the remote NPortID which did not respond.
The Remote NPortID in this example was "login->SCSI_ID =
The Remote NPortID in this example was "login->SCSI_ID =
0x00000000001E1900". This is the target that the client LPAR is no longer able to reach, returning ENODEV.This is not a VIOS issue. The VIOS is only reporting back the message that it is getting from the SAN.
Recommendation
It is important to understand what was going on, on the client (AIX/Linux/IBM i) and the SAN (switch and storage side) around the time this error was logged by the VIOS in order to try to determine why the device is not available.
Engage your SAN administrator to check what is the status of the target, and why it does not seem to be available in the SAN.
For SAN-related questions, contact your local SAN Switch or Storage Support Representative.
[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSPHKW","label":"PowerVM Virtual I\/O Server"},"ARM Category":[{"code":"a8m3p000000hA8JAAU","label":"PowerVM VIOS-\u003ENPIV {NPIV}-\u003EVIOS VFC"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"3.1.2;3.1.3;3.1.4"}]
Was this topic helpful?
Document Information
Modified date:
03 July 2024
UID
isg3T1025124