Troubleshooting
Problem
Dual VIOs serving AIX clients with virtual SCSI (vSCSI) storage backed by Logical Volume backing devices on VIOS rootvg.
Symptom
AIX client originally configured with vSCSI storage backed logical volumes on VIOS1.
Cause
New vSCSI disks backed by LVs configured on VIOS2 are discovered by the clients as 2nd MPIO path instead of new disks.
Environment
PowerVM VIOS 2.2
AIX 6.1, 7.1, or 7.2 using vSCSI storage backed by Logical Volumes in (VIOS) rootvg
Diagnosing The Problem
Determine if VIOS2 was cloned from VIOS1. This can be verified by comparing the VG IDENTIFIER for rootvg on both VIOs:
$ lsvg rootvg ->Get VG IDENTIFIER value from both VIOs
To determine the LV IDENTIFIER for the Logical Volume Backing Device(s) in question on both VIOs, run:
$ lslv LVname
Sample output of problematic environment:
rootvg VG ID on both VIOs: 00fae9d600004c000000015af6c5ad20. This results in the logical volumes mapped to the client having the same "unique ID" (in this case, 00fae9d600004c000000015af6c5ad20.15) based on the rootvg VG ID.
vio1 LV ID: 00fae9d600004c000000015af6c5ad20.15 lv01
vio2 LV ID: 00fae9d600004c000000015af6c5ad20.15 lv01-1
Client "unique_id": "382300fae9d600004c000000015af6c5ad20.1505VDASD03AIXvscsi"
This in turn causes the second mapping to be seen by the client as a second MPIO path to the disk, instead of a new disk.
Resolving The Problem
If VIOS2 was cloned from VIOS1, restoring VIOS2 from backup will not help as the VG/LV identifier will also be restored. The VIOS will need to be reinstalled and rebuilt. To rebuild the VIOS, you may use the viosbr command to backup the configuration. Then restore the configuration onto the generic install of the VIO.
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Document Information
Modified date:
19 February 2022
UID
isg3T1025113