IBM Support

HSM doesn't delete or migrate data sets per Management Class criteria

Troubleshooting


Problem

SMS-managed data sets are not migrated or expired per the management class criteria.

Symptom

Data sets expected to be expired, deleted, or migrated remain on primary volumes.

Cause

There are various reasons why data sets don't get managed by HSM as expected.

Environment

SMS-managed data sets on volumes being managed by DFHSM.

Diagnosing The Problem

There are various reasons why data sets aren't deleted or migrated by HSM per the management class criteria.

1. The data sets must be on a volume that is space managed by HSM. Check the storage group of the volume that the problem data sets are on. The storage group must have AUTOMIGRATION set to 'P', 'I' or 'Y'. If AM=N is set, the volume is not space managed by HSM, and no data sets are deleted or expired from the volume during space management.
2. For delete processing, HSM does not expire a data set by management class criteria if there is an explicit expiration date for the data set.  Check in ISPF 3.4. by selecting the Information menu option to see whether an expiration date is set.  If the EXPIRATION DATE shows '***None***', the data set expires according to the management class criteria.  If there is an explicit expiration date shown in the ISPF 3.4 display, the data set expires on that date.
3. A primary volume must exceed its LOW THRESHOLD specified in the storage group definition for the volume, or the volume is not space managed. Primary Space management is performed in two passes. The first pass deletes expired data sets and performs PARTREL processing on eligible data sets. After the first pass, if the volume exceeds the LOW THRESHOLD, HSM migrates eligible data sets.  If the volume doesn't exceed the LOW THRESHOLD, no data sets migrate.

A patch is available that generates an ARC0734I message for SMS-managed data sets that fail to expire or migrate as expected.

The patch is enabled with:

HSEND PATCH .MGCB.+26 X'FF'

Check the HSM Migration Activity Log following the completion of the next Primary Space Management cycle and search for an ARC0734I message with the data set name in it. The message has return and reason codes that explain why the data set wasn't managed. Refer to the MVS System Messages manual for an explanation for the return and reason codes.

The patch is disabled with:

HSEND PATCH .MGCB.+26 X'00'

Resolving The Problem

Correct the conditions indicated by the diagnostics. If the reason isn't found or can't be resolved, contact IBM support.

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Document Information

Modified date:
03 September 2021

UID

isg3T1023379