IBM Support

Backup to a container storage pool may fail with ANR0532W

Troubleshooting


Problem

A long backup or archive performed to a directory-container storage pool might fail with server-side message ANR0532W.

Symptom

Backup failure can be reported with the following server activity log messages:
ANR1181E sdtxn.c: Data storage transaction was aborted.~
ANR0532W smnode.c: Transaction #:## was aborted for session # for node <node_name>.

Cause

The reason why the transaction was aborted is because server waited for longer time than specified by the CONTAINERRESOURCETIMEOUT to complete the store operation in the container pool. 
The CONTAINERRESOURCETIMEOUT option specifies how long the server waits to complete
A data store operation to a container storage pool.
When a timeout occurs the data stores operation ends and the request for the container resource is canceled.

Environment

Spectrum Protect server 7.1.7 or higher on any platforms.

Diagnosing The Problem

The dsmffdc.log file might report the following message:
[FFDC_GENERAL_SERVER_ERROR]: (sdtxn.c:) Txn 0:## ran for # seconds exceeding max runtime of 180.
 
Note: 180 is the default value for CONTAINERRESOURCETIMEOUT.

Resolving The Problem

Increase the value of CONTAINERRESOURCETIMEOUT to a higher value to allow the server to complete the transaction.
Using the following command:
Setopt CONTAINERRESOURCETimeout <value>

Document Location

Worldwide

[{"Line of Business":{"code":"LOB26","label":"Storage"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"ARM Category":[{"code":"a8m50000000Ci5XAAS","label":"Server"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.1.7"}]

Document Information

Modified date:
28 October 2020

UID

ibm16255624