IBM Support

System Requirements for Rational Asset Manager version 7.2.0.x

Preventive Service Planning


Abstract

This document summarizes the system requirements for IBM Rational Asset Manager version 7.2.0.x

Content

Hardware
Linux
Microsoft Windows
UNIX
Supported Web Browsers
Supported Application Servers
Supported Database Servers
Supported LDAP
WebSphere Service Registry and Repository
Configuration and change management
Supported Eclipse Environments
VMWARE




See Change History for updates.

GLOSSARY:

Hardware: The Hardware on which the product is supported.

Operating System: The operating system on which the product is supported.

Revision: Operating System Patch or Service Release or selected Version with which the product is supported.

RFE: Request for Enhancement. A change request focused on support for the platform or operating system.

VRMF: VRMF is the product release numbering format that is being implemented throughout the IBM and the Rational product lines. Review education document 7008656 for a explanation of the VRMF - Maintenance Delivery Vehicle (MDV) terminology used by Rational products.





Minimum Hardware Requirements

Rational Asset Manager v7.2.0.x
Component
Minimum Requirements for Windows and Linux Servers
Processor
2 GHz Intel Pentium 4, dual CPU (or higher for best results)
Display
1024 x 768 display using 256 Colors (or higher for best results)
Memory
1 GB RAM (with embedded WebSphere Application Server and DB2 Enterprise Server Edition) or 2 GB (with Rational ClearCase or Rational ClearQuest clients)
Disk space
5 GB (with embedded WebSphere Application Server and DB2 Enterprise Server Edition); if you plan to add Rational ClearCase or Rational ClearQuest clients, consult their disk space requirements.
Other
Microsoft mouse or compatible pointing device

Rational Asset Manager v7.2.0.x
Component
Minimum Requirements for AIX Servers
Processor
2 GHz IBM POWER5 (or higher for best results)
Display
1024 x 768 display using 256 Colors (or higher for best results)



Memory
Non-production environments: 1 GB RAM (with embedded WebSphere Application Server and DB2 Enterprise Server Edition)

Production environments: 2 GB RAM (with embedded WebSphere Application Server and DB2 Enterprise Server Edition) or 4 GB RAM (with Rational ClearCase or Rational ClearQuest clients)
Disk space
5 GB (with embedded WebSphere Application Server and DB2 Enterprise Server Edition); if you plan to add Rational ClearCase or Rational ClearQuest clients, consult their disk space requirements.
Other
Microsoft mouse or compatible pointing device

RationalĀ® Asset Manager server requires the Rational License Server to distribute license keys to clients.
- Use Rational License Server for Windows 7.0.1 or 7.1.
- Use Rational License Server for UNIX and Linux 7.0.0.1.

In this release, Rational Team Concert is a required component that you must install as part of the Rational Asset Manager installation. Rational Team Concert requires an additional 250MB+ of disk space for the server files, and the Rational Team Concert database needs 5GB+ of free space.

You cannot install Rational Asset Manager into an existing Rational Team Concert server, nor can you update Rational Team Concert in the Rational Asset Manager 7.2 server.

In a WebSphere network deploy environment, Rational Team Concert cannot be deployed onto clusters; Rational Team Concert has to be deployed on an application server only.

This release supports IPV6 host names but does not support IPV6 addresses.
If you are using IPV6, use host names to specify the Rational Asset Manager path for Web and Web services, and also for the Rational Team Concert connection.


Rational Asset Manager v7.2.0.x
Component
Minimum Requirements for Clients
Processor
1.4 GHz Intel Pentium 4 (or higher for best results)
Display
1024 x 768 display using 256 Colors (or higher for best results)
Memory
512 MB RAM
Disk space
500 MB
Other
Microsoft mouse or compatible pointing device


Linux

Rational Asset Manager v7.2.0.x
Hardware
Operating System
Comments
Client & Server
x86-32
Red Hat Enterprise Server 5
AS (update 4)
Red Hat Enterprise Server 4
AS (update 7)
SUSE Enterprise Server 10
SP3
x86-64
Red Hat Enterprise Server 5
AS (update 4)
SUSE Enterprise Server 10
SP1 (x86_64) - Kernel
2.6.16.46-0.12-smp (1)
zSeries
SUSE 9
Not supported with 7.2 and later

SUSE 10
Supported as of 7.1.1 (64 bit)

RHEL 5
Supported as of 7.1.1 (64 bit)

Note: The following software is required for installing the Rational Asset Manager Eclipse client on Linux: GNU Image Manipulation Program Toolkit (GTK+), Version 2.2.1 or later and associated libraries (GLib, Pango).


Microsoft Windows

Rational Asset Manager v7.2.0.x
Hardware
Operating System
Comments
x86-32

x86-64
Windows 7 Ultimate, Professional, and Enterprise Editions
Supported as of 7.2.0.1
Windows Server 2008 Enterprise Edition
Supported as of 7.1.0.1
Windows Vista Business Edition
SP1
Supported as of 7.1.0.1
Windows Server 2003 - Enterprise and Standard Editions
SP2
Server only
Standard Edition not supported as of 7.1.1
Windows XP Professional
SP2 and
SP3 (supported as of 7.1.0.1)
32 bit only

Note: Review technote 1263677 for important details about support for 64-bit operating systems.



UNIX

Rational Asset Manager v7.2.0.x
Hardware
Operating System
Comments
POWER
AIX 5.3
64-bit
Supported as of 7.1.0.1
(Server only)
POWER
AIX 6.1
64-bit
Supported as of 7.1.1
(Server only)


Web Browsers

Rational Asset Manager v7.2.0.x
Web Browser
Version
Comments
Firefox
1.5.x
Not supported as of 7.1.1
2
Not supported as of 7.2
3 and 3.5
Supported for 7.2
Internet Explorer
6 SP1

7

Note: Java Runtime Environment (JRE) version 1.5.0_06 or later is also required.



Supported Application Servers

Rational Asset Manager v7.2.0.x
Product
Version
Comments
WebSphere Application Server 6.0.x
6.0.2.25
Not supported as of 7.1.1
WebSphere Application Server 6.1.x
6.1.0.29

6.1.0.27

Supported for 7.2.0.2

Supported for 7.2.0.1


Note that you cannot deploy Rational Team Concert to a cluster.

In addition to requiring fix pack 25 to be installed for both the application server and SDK, the following iFix is also required.
http://www-01.ibm.com/support/docview.wss?uid=swg24023024
WebSphere Application Server 7.0
7.0.0.7
Supported as of 7.2.0.1
WebSphere Application Server embedded (eWAS)
6.1.0.29

6.1.0.27

Included in 7.2.0.2

Included in 7.2.0.1
Tomcat
5.5



Supported Databases

Rational Asset Manager v7.2.0.x
Database
Version
Comments
DB2 Enterprise Server Edition
8.2
Not supported as of 7.1.1
9.1
Not supported as of 7.2.0.2
9.5.4
Requires SQL09017. The fix pack for 9.5.4 is available here: http://www-01.ibm.com/support/docview.wss?uid=swg24023213&rs=0&cs=utf-8&context=SSEPGG&dc=D400&loc=en_US&lang=en&cc=US

Note: Rational Asset Manager includes a limited use license of DB2 9.5 Enterprise Edition. DB2 9.1 is the last edition to support 32-bit Linux. All newer versions are 64-bit only.
9.7
Supported as of 7.2.0.2
Oracle
10g
Supported as of 7.1.0.1
10.2(g)
Oracle10g version 10.2.0.1 is supported for 7.1.0.1 and higher.
11g

SQL Server
2005

2008
Support is for 2005 Service Pack 2

Supported as of 7.2.0.1

LDAP

Rational Asset Manager v7.2.0.x
Product
Version
Comments
Microsoft Active Directory Server
2003 Server

Tivoli Directory Server
6.2
Supported as of 7.1.1.1

WSRR

Rational Asset Manager v7.2.0.x
Product
Version
Comments
WebSphere Service Registry and Repository
6.3





7.0
Supported as of 7.1.1

Versions 6.0.2.1, 6.1, and 6.2.0.2 are not supported as of v7.2

Supported as of 7.2.0.1

Note: Integrating Rational Asset Manager and WSRR is not supported with the embedded version of WebSphere Application Server.

Configuration and change management

You can optionally use Rational Asset Manager in conjunction with any of the following software configuration and and change management systems:



Rational Asset Manager v7.2.0.x
Product
Version
Comments
Rational ClearCase
7.0.1

Rational ClearCase
7.1
Supported as of 7.1.1
Rational ClearQuest
7.0.1

Rational ClearQuest
7.1
Supported as of 7.1.1
Rational Team Concert
1.0
1.0.x is not supported with 7.2 and later.
Rational Team Concert
1.0.1
Supported as of 7.1.1
Rational Team Concert
2.0.0.1
Supported as of 7.2
Tivoli Change and Configuration Management Database (CCMDB)
7.1.1.5
Supported as of 7.2.0.2
Tivoli Change and Configuration Management Database (CCMDB)
7.1.1.1

CVS
1.11.22
1.11.22 or later

Eclipse and IDE Support


The Rational Asset Manager Eclipse client can be installed into, or extend, the following Eclipse IDEs:

Rational Asset Manager v7.2.0.x
Product
Version
Comments


Eclipse
3.2.2
Not supported with 7.1.1 and later
3.3

3.4 P2
Supported as of 7.1.0.1
Using the Rational Asset Manager Update site
Eclipse Modeling Framework (EMF) 2.2 or higher

Eclipse BIRT plugins 2.1.2 or higher

IBM Rational Software Development Platform products (Rational Application Developer, Rational Software Architect)
7.0.0.5
Not supported with 7.1.1 and later
7.5
Supported as of 7.1.0.1
Rational Method Composer
7.5

Rational Software Modeler
7.0.5.1

Rational Systems Developer
7.0.5.1

WebSphere Business Modeler
6.1.2

6.2

7

WebSphere Integration Developer
6.1.2

6.2

7

Note: Java Runtime Environment (JRE) version 1.5.0_06 or later is also required.

VMWARE

Rational Asset Manager v7.2.0.x
Product
Version
Comments
GSX and ESX
3.5
Supported as of 7.1.1


Change History (click to expand)

[{"Product":{"code":"SSUS84","label":"Rational Asset Manager"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":"Documentation","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.2;7.2.0.1;7.2.0.2","Edition":"All Editions"}]

Document Information

Modified date:
16 June 2018

UID

swg21382926