Troubleshooting
Problem
When IBM Collaborative Lifecycle Management(CLM) v6.0.6.1 is installed on a Microsoft® Windows® operation system with Chinese locale, new custom attribute does not appear in the work item in a new RTC project area.
Symptom
The main symptoms you might encounter are:
- New custom attribute does not appear in the work item in a new IBM Engineering Workflow Management (formerly RTC) project area. When you restart RTC server, the custom attribute is present properly in the work item.
- If you use WebSphere Application Server, it hangs when you stop the WAS Service.
- The Money that Matters sample fails to create and throws CRJCA052E: Read time out exception.
Cause
The problem is caused by the defect Fail to create Money that Matters sample in CHT locale
Environment
CLM v6.0.6.1 on a Windows® operation system with Chinese(both Simplified and Traditional Chinese) locale
Diagnosing The Problem
RTC active service shows the work item post-save operation is stuck for hours and it involves writing to the Lucene index for full-text search. The stack contains:
com.ibm.team.fulltext.common.internal.analysis.ChineseTokenizerWorkaroundFilter.incrementToken
Resolving The Problem
- Apply ifix011 to CLM v6.0.6.1 or
- Upgrade to CLM v7.0 or later
Document Location
Worldwide
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Product Synonym
RTC;CLM
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Document Information
Modified date:
16 July 2020
UID
ibm16249863