IBM Support

QRadar: [ERROR] Host is not active console

Question & Answer


Question

When I tried to issue IBM QRadar command from the CLI after a new install of 3199 (console) appliance or vm, I am getting this error. 
[ERROR] Host is not active console
I have tried multiple reboots of the system, but the error is still the same. Any help on how to resolve this error?

Cause

You might mostly ran into this issue when after installing the appliance or the IBM QRadar software when you have not accepted the End User License Agreement (EULA). It is also possible that the system has not been fully initialized. Therefore, it does not know if it active console. Accepting the EULA means you have to login into the web user interface (UI) for the first time, but if you don't have the correct password for the admin user then getting this error from the CLI when you attempt to change the admin password is expected. 

Answer

This issue can be resolved by running these commands from the CLI
cp /opt/qradar/support/lib/support.sh /opt/qradar/support/lib/original_support.sh
sed -i "/local state=\"false\"/s//local state=\"active\"/" /opt/qradar/support/lib/support.sh
systemctl restart tomcat

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000GnbbAAC","label":"QRadar"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
23 June 2020

UID

ibm16237822