IBM Support

ibm-minio-ow-minio-ibm-minio-0 to 3 are in CrashLoopBackOff status

Troubleshooting


Problem

ibm-minio-ow-minio-ibm-minio-0, ibm-minio-ow-minio-ibm-minio-1, ibm-minio-ow-minio-ibm-minio-2, and ibm-minio-ow-minio-ibm-minio-3 are in CrashLoopBackOff status and it is resulting in user not being able to add sources.

Performing kubectl logs displays following information:

oc logs -f ibm-minio-ow-minio-ibm-minio-0 
ERROR Unable to initialize backend: Disk http://ibm-minio-ow-minio-ibm-minio-0.ibm-minio-ow-minio-ibm-minio-headless-svc.cp4s.svc.cluster.local:9000/workdir/data: corrupted backend format, please join https://slack.min.io for assistance

Cause

This CrashLoopBackOff is caused by PVC (Persistent Volume Claim) not bound or unsuccessfully processed after bound.

Environment

Red Hat OpenShift version: 4.3
Cloud Pak for Security version: 1.3
Cloud Environment: IBM Cloud

Resolving The Problem

In order to bring minio pods in running state, perform following steps:
  1. Remove minio helm chart:
    helm delete --purge ibm-minio-ow-minio --tls
  2. Remove pic associated with minio deployment:
    kubectl get pvc -o name | grep minio | xargs kubectl delete
  3. Redeploy minio helm chart:
    ibm-security-foundations-prod/ibm_cloud_pak/pak_extensions/support/runcr.sh minio ow-minio
  4. Wait for 20 to 30 minutes for changes to take effect

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTDPP","label":"IBM Cloud Pak for Security"},"ARM Category":[{"code":"a8m0z0000001h8uAAA","label":"Install"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.3.0"}]

Document Information

Modified date:
02 May 2022

UID

ibm16236996