IBM Support

Security Bulletin: IBM Workload Scheduler potentially vulnerable to cross site scripting

Security Bulletin


Summary

Dynamic Workload Console for IBM Workload Scheduler is potentially affected by cross site vulnerability: after loginit is possible to modify one of the outgoing requests in this loading process and obtain a response that generates an alert in the browser, using both HTTP methods, GET and POST.

Vulnerability Details

CVEID:   CVE-2020-4380
DESCRIPTION:   IBM Tivoli Workload Scheduler is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.
CVSS Base score: 5.4
CVSS Temporal Score: See: https://exchange.xforce.ibmcloud.com/vulnerabilities/179160 for the current score.
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N)

Affected Products and Versions

Affected Product(s)Version(s)
IBM Workload Scheduler9.3.0.4 and earlier

Remediation/Fixes

APAR IJ23373 has been opened to address the cross site scripting vulnerabilities for IBM Workload Scheduler.
The following limited availability fix for IJ23373 is available for download on FixCentral

9.3.0-TIV-DWC_FP0004_IJ23373
 
to be applied on top of Dynamic Workload Console 9.3.0 FP04.
APAR IJ23373 has been included in 9.4.0-TIV-TWS-FP0006 and 9.5.0-TIV-TWS-FP0002.

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

References

Off

Acknowledgement

The vulnerability was reported to IBM by Alexander Tafurt

Change History

08 Jun 2020: Initial Publication

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Document Location

Worldwide

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SS8GJD","label":"IBM Workload Automation"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
19 June 2020

UID

ibm16223030