IBM Support

PowerVM/VIOS Getting error "WARNING- Could not get udid info for 'hdiskX'" post upgrading to VIOS 3.1

Troubleshooting


Problem

Losing storage configuration after upgrading VIOS to 3.1

Symptom

Losing storage configuration after upgrading, upon attempting to restore the below errors appear;
WARNING- Could not get udid info for 'hdiskX'
WARNING- Error occured during validation
WARNING- Error occured during validation of hardware devices

Cause

This happens when the system has third party software that has not been taken into consideration upon upgrading, i.e., a custom mksysb image containing the third party software had not been built and had not been used for the upgrade process.

Environment

PowerVM/VIOS

Diagnosing The Problem

Upon receiving errors;
WARNING- Could not get udid info for 'hdiskX'
WARNING- Error occured during validation
WARNING- Error occured during validation of hardware devices
You can double check by using the lslpp command, or checking the lslpp.hac file in the general directory of the VIOS snap, and the entries for the missing third party software would be there.

Resolving The Problem

The recommended way of resolving would be to roll back and re-attempt the VIOS Upgrade process after building a custom mksysb image containing the needed third party software.
You can check the lslpp.hac file on the general directory of the VIOS snap, or list the available software products on your system, since the output can be long, you can display the listing one page (screen) at a time, use the lslpp command piped to the pg command;
lslpp -l -a | pg
For more information regarding the lslpp command, please refer to;
Listing available software products (lslpp command)
After establishing the third party software that needs to be included, you can create a customized image, you need to install the VIOS using the IBM provided image on a VIOS partition and install the desired software that is applicable to your environment.​
A customized VIOS mksysb image can be created using the backupios command and the same can be used to deploy on all the VIO Servers across the Datacenter.
backupios -mksysb -file <filename.mksysb>
For more information, please check the links provided below;
Miscellaneous information about upgrading Virtual I/O Server
VIOS 3.1 - viosupgrade process
SUPPORT

If you require more assistance, use the following step-by-step instructions to contact IBM to open a case for software with an active and valid support contract.  

1. Document (or collect screen captures of) all symptoms, errors, and messages related to your issue.

2. Capture any logs or data relevant to the situation.

3. Contact IBM to open a case:

   -For electronic support, see the IBM Support Community:
     https://www.ibm.com/mysupport
   -If you require telephone support, see the web page:
      https://www.ibm.com/planetwide/

4. Provide a clear, concise description of the issue.

 - For more information, see: Working with IBM AIX Support: Describing the problem.

5. If the system is accessible, collect a system snap, and upload all of the details and data for your case.

 - For more information, see: Working with IBM AIX Support: Collecting snap data

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Author: Ahmed Deif

Document Location

Worldwide

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Product Synonym

PowerVM/VIOS

Document Information

Modified date:
27 April 2022

UID

ibm16219192