IBM Support

QRadar Risk Manager: How do I populate the risk tab's connection graph

Troubleshooting


Problem

When you open Connections in the Risk tab, the Connection graph is blank.

Symptom

Look within /var/log/qradar.log or /var/log/qradar.error for messages referencing simArc issues on your QRM host.

Cause

If you have no data in the simArc directory, then nothing is created for the connections graph. The Connections screen displays simArc data, which is built from the flows and firewall events generated at the event processor.

Diagnosing The Problem

  1. Click Risk tab.
  2. Click Connection.
  3. View Connection Graph.
    image 5546
  4. SSH to the Console as the root user.
  5. SSH to QRM host.
  6. Display the contents of the simArc directory by using the command.
      ls /store/ariel/simarc
Results Connections Graph is blank, and the simArc directory has no data.

Resolving The Problem

Note: Connections are built only for the default domain. The Connections graph for Multi-tenant is unsupported.

Connections Graph is blank

If you have no data, then nothing is created for the connections graph. The Connections screen displays simArc data, built from the flows and firewall events generated at the event processor. These simArcs connections represent bidirectional flows (local at either src or dst), which are aggregated based on src, dst, protocol destination Port, and allowDeny. The later allowDeny field is true for an arc constructed from a flow, but arcs can also be constructed from firewall events, to indicate a denied connection attempt. If arcs are based on events, the device ID and event count are also appended.

Flows not translating to arcs

If you find that flows are not being translated to arcs, you need to check that the flows are bidirectional and meet the criteria of either originating or destined for the customer network or both - Local to Local (L2L). You need to ensure the flows refer to open ports on known assets.

No Data in the simArc directory

If there is no data in the simArc directory on QRM, the issue is usually related to where the data is being sent. You might need to SSH to the firewall event's event processor and also check the same directory by using the command:

ls /store/ariel/simarc

Check whether there is data in the local simarc directory. If there is no data, then it is not a QRM-related issue. Event Processors  /store/ariel/simarc  gets copied to QRM's /store/ariel/simarc. If there is data in the QRM simarc directory, uses it to create connection views, and the Connections graph displays results.

Document Location

Worldwide

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Document Information

Modified date:
06 January 2021

UID

ibm16211857