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** Troubleshooting ** "Security Error 1 ... ValidateNativeUser" errors when using Controller

Troubleshooting


Problem

Inside the Controller client, user receives an error.

Symptom

The error will vary (depending on what the user was doing at the time), but it will contain the phrases "Security Error 1" and "ValidateNativeUser".
For example (scenario #1):
image 3122

Cause

From time to time (every few minutes), the Controller system will check/re-check that the user is actively connected (and logged-on/authorised) to the system.
  • Specifically, the Controller client and Controller server exchange messages to prove that the user is still logged into the system.
This "Security Error 1 ... ValidateNativeUser" message indicates that is client<=>server authentication check mechanism has failed. 
  • There are many known causes for this failure (see below for examples):
Scenario #1 (intermittent) - Error triggered by IIS application pool recycle event
  • The problem will seem to be occurring at random (intermittent), although it may actually occur at regular intervals of time
  • See separate IBM Technote #1030676 for more details
  
Scenario #2 - The user has been deliberately (intentionally) forcibly logged off (in the background) from the application server
  • See separate IBM Technote #163763 for more details
  
Scenario #3 - The network connection (from the client to the Controller application server) has been lost. 
  • See separate IBM Technote #163763 for more details
  
Scenario #4 - Limitation of Controller if form requires Microsoft Excel - Compatibility Checker
  • See separate IBM Technote #291519 for more details
Scenario #5 - Defect (reference APAR PI86276) in Controller 10.3.0 (and earlier)
  • Triggered if enter wrong password in logon box, and then try to close Excel
  • See separate IBM Technote #567041 for more details
 
Scenario #6 (RARE) - Firewall (between master & slave servers) blocking communication from the 'slave' server to the "IBM Cognos Controller User Manager" service (running on the 'master' server). 
  • See separate IBM Technote #298641 for more details
Scenario #7 (RARE) - Defect (reference APAR PI36558) in old/unsupported versions of Controller 10.2.1 (and earlier)
  • See separate IBM Technote #526913 for more details
Scenario #8 (RARE) - Triggered by closing Excel at the 'wrong' time earlier, solved by using EXCEL_EAGERLOAD
  • See separate IBM Technote #728985 for more details
Scenario #9 - Design limitation of Controller, if run TBwD report first, and then launch a new/fresh copy of Excel
  • See separate IBM Technote #712173 for more details.

Resolving The Problem

Scenario #1
Modify the Controller application server's IIS application pool recycle schedule, so that it only recycles during downtime (no users on the system).
  • See separate IBM Technote #1030676 for more details
  
Scenario #2
This is by design. In general, the user should simply close Controller, and re-launch Controller. 
  • See separate IBM Technote #163763 for more details
Scenario #3
This is by design. In general, the user should simply close Controller, and re-launch Controller. 
  • See separate IBM Technote #163763 for more details
Scenario #4
Ensure that you action any Excel information/warning message during the save process.  
  • See separate IBM Technote #291519 for more details
Scenario #5
Upgrade to Controller 10.3.1 or later.
  • See separate IBM Technote #567041 for more details
Scenario #6 (RARE)
Disable the firewall between the 'master' and 'slave' Controller application servers.
  • See separate IBM Technote #298641 for more details
Scenario #7 (Old/unlikely)
Upgrade to Controller 10.2.1 Fix Pack 2 (10.2.5120.72) or later.
  • See separate IBM Technote #526913 for more details
 
Scenario #8 (RARE)
Close windows in a specific order.
  • See separate IBM Technote #728985 for more details
 
Scenario #9
Design limitation of Controller.
  • See separate IBM Technote #712173 for more details

Document Location

Worldwide

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Document Information

Modified date:
30 April 2020

UID

ibm16204010