IBM Support

What are possible causes for an IBM Rational Developer for i client to disconnect unexpectedly?

Troubleshooting


Problem

Users notice their IBM Rational Developer for i RSE connections drop frequently if the session idles for a period of time.

Symptom

Remote System Explorer (RSE) sessions hang trying to perform an action which results in a window, "RSEF1002 Operation Failed."
"File system input or output error" or a message in the RSE panel, "Unexpected error retrieving library list."

Cause

Network applications (bridges, routers, virtual private network configurations) often use a 30 minute timeout, then "forget" the connection.
By default, the IBM i is configured with a 120 keep-alive value.

Environment

Windows and IBM i

Resolving The Problem

1.  Log in to the IBM i and type the command chgtcpa, prompt PF4 to check the value.  
2.  Change the TCP Keep alive value to 15 minutes so the keep-alive polls are more frequent.

Document Location

Worldwide

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Document Information

Modified date:
17 February 2026

UID

ibm16195408