IBM Support

How to fix incorrect page rotation of AFP documents that displayed correctly in previous versions of the OnDemand client

Troubleshooting


Problem

After upgrading from an older version of the OnDemand Windows client, some AFP documents are rotated incorrectly when viewed or printed. The documents displayed correctly in previous versions of the OnDemand client.

Cause

The problem occurs when there is a conflict in the AFP data between Page Orientation and Text Layout.  For example, in the AFP data, Page Orientation might be set to Landscape and Text Layout might be set to Portrait.

Resolving The Problem

There are two possible solutions to this problem. The first solution involves adding entries to the ftdport2.ini configuration file. The second solution involves changing the Content Manager OnDemand application definition. Both solutions might be required to completely correct the problem.
Adding entries to the ftdport2.ini configuration file
NOTE:  This solution affects only the workstations on which you make the ftdport2.ini file update.
 
The ftdport2.ini file contains modifiable parameters that can affect how AFP reports display. To configure the OnDemand client to display the AFP document with the correct rotation, add the two entries shown below to the ftdport2.ini file, which is located in the OnDemand Client bin directory.  For example, unless you chose a different install path, the file for the V10.5 OnDemand 64-bit client on a 64-bit workstation is located in C:\Program Files\IBM\OnDemand Clients\V10.5\bin.
Using a text editor, such as Microsoft Notepad, open the file and find the [Misc] heading. Add these two lines anywhere under the [Misc] heading:
 
CutSheet=TRUE
FixedAutoOrientation=TRUE
Restart the OnDemand client for the changes to take effect.
Changing the Content Manager OnDemand application definition
NOTE:  This solution affects all users who view or print data that has been stored by using the Content Manager OnDemand application definition that is changed.
 
If adding the two entries to the ftdport2.ini file does not fix the problem, change the following field values in the Content Manager OnDemand application definition: 
  • Orientation: 0 (zero) 
  • Paper Size: Autosize

Document Location

Worldwide

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Document Information

Modified date:
07 October 2021

UID

ibm16174423