IBM Support

Detailed system requirements for the web applications components (connection manager, manager, and service interface) to v11.3 of the IBM® InfoSphere® Optim™ solutions

Detailed System Requirements


Abstract

Web applications are web-based interfaces to the environment for the IBM® InfoSphere® Optim™ solutions. Use web applications to manage this environment and to allow users to run and manage data management services from a browser.

Content

Web applications includes the following:

  • Connection manager stores Optim directory connection information for the components of the Optim solutions.
  • Manager can be used to manage, run, and monitor data management services.
  • The service Interface provides a public interface into the environment for the Optim solutions. You can develop a web application that uses the service interface to manage, run, and monitor data management services. The service interface can therefore be used in addition to or instead of the manager.

The connection manager, the manager, and the service interface are installed as WAR files. You must deploy the WAR files to a Java EE application server before you can use the manager or the service interface. You can deploy the manager or the service interface to WebSphere Application Server Community Edition or to any Java EE application server of your choice. A copy of WebSphere Application Server Community Edition is included with the Optim solution. For easier configuration, deploy the connection manager, the manager, and the service interface to a single application server.

Hardware requirements
IBM Installation Manager
Other software requirements
Compatibility with previous versions of Optim components
More information

Hardware requirements:

  • Memory: Minimum of 1GB RAM; For best results: 2GB RAM
  • Disk space:
    • Connection manager, manager, and service interface: Minimum of 900MB disk space
    • WebSphere Application Server Community Edition: Minimum of 200MB disk space
    • Installation Manager (if not already installed): Minimum of 150MB disk space
    • Temporary disk space: 4GB for Microsoft® Windows® and 8GB for Linux® and UNIX® if you download the server installation image
If you install from optical disc, a DVD drive is required for installation.

If you deploy the connection manager, the manager, and the service interface to an application server other than WebSphere Application Server Community Edition, add the required hardware for that application server to the hardware requirements.

IBM Installation Manager:

The connection manager, the manager, the service interface, and WebSphere Application Server Community Edition are installed by using IBM Installation Manager. Installation Manager is packaged on the installation disc. Run the appropriate installation program or script on the installation disc to install Installation Manager.

Other software requirements:

The connection manager, the manager, and the service interface require a Java EE application server. The connection manager, the manager, and the service interface have been certified with the following application servers:

  • WebSphere Application Server Community Edition (included with the solution)
  • WebSphere Application Server 8

The connection manager, the manager, and the service interface can be installed on the following operating systems:

AIX®

  • AIX 6.1 (64-bit with Optim server running in 32 bit mode)

Linux
  • Red Hat Enterprise Linux 5.x AS/ES x86-32 (with Optim server running in 32-bit mode)
  • Red Hat Enterprise Linux 5.x AS/ES x86-64 (with Optim server running in 32-bit mode)

  • The following 32-bit libraries must be installed on 64-bit versions of Red Hat Enterprise Linux:
    • gtk2.i686
    • libXtst.i686
    • compat-libstdc++
  • Red Hat Enterprise Linux 6.x AS/ES x86-32 (with Optim server running in 32-bit mode)
  • Red Hat Enterprise Linux 6.x AS/ES x86-64 (with Optim server running in 32-bit mode)
    The following 32-bit libraries must be installed on 64-bit versions of Red Hat Enterprise Linux:
    • gtk2.i686
    • libXtst.i686
    • compat-libstdc++
  • Red Hat Enterprise Linux 7.x AS/ES x86-32 (with Optim server running in 32-bit mode) - Requires Optim 11.3.0.6
  • Red Hat Enterprise Linux 7.x AS/ES x86-64 (with Optim server running in 32-bit mode) - Requires Optim 11.3.0.6
    The following 32-bit libraries must be installed on 64-bit versions of Red Hat Enterprise Linux:
    • gtk2.i686
    • libXtst.i686
    • compat-libstdc++
  • SUSE Linux 11 32-bit (with Optim server running in 32-bit mode)
  • SUSE Linux 11 64-bit (with Optim server running in 32-bit mode)
    The following 32-bit libraries must be installed on 64-bit versions of SUSE Linux:
    • gtk2.i686
    • libXtst.i686
    • compat-libstdc++

Solaris
  • Oracle Solaris 10 64-bit (with Optim server running in 32-bit mode)

Windows
  • Microsoft Windows 7 (Professional, Enterprise, Ultimate) x86-32
  • Microsoft Windows 7 (Professional, Enterprise, Ultimate) x86-64
  • Microsoft Windows Server 2008 Enterprise Edition x86-64

The manager web interface requires the following browsers with Adobe Flash Player V10.0 or later installed on the browser.
  • Chrome 35.0 or later
  • Microsoft Internet Explorer 10.0 or later
  • Mozilla Firefox 29 or later

The connection manager uses a database to store configuration information and artifacts. The connection manager database must be installed on a database supported for the Optim directory,

Compatibility with previous versions of Optim components:

Version 11.3 of the manager and the service interface are compatible with version 9.1 of Optim data management solution components but not with earlier versions. When using version 11.3 of the service interface you cannot use work order related services programmatically, as is possible with version 9.1 of the solution components but not with earlier versions. The work order functionality continues to be available in the user interface.

If you upgrade version 9.1.0.1 of the manager and the service interface to version 11.3 or a later 9.1 version, you must also upgrade all solution components to the same version to ensure compatibility. You must also upgrade WebSphere Application Server Community Edition to the version that is included with the upgraded components.

More information

For more information about the manager and the service interface, see IBM InfoSphere Optim Data Growth Solution or IBM InfoSphere Optim Test Data Management Solution in Knowledge Center.

[{"Product":{"code":"SSGMCR","label":"Optim"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Solutions","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"11.3.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
03 June 2019

UID

swg27043070