IBM Support

Sharing a CICS 5.1 CSD after applying UI42619 and UI43662

Question & Answer


Question

After applying UI42619 for APAR PI60388 and UI43662 for APAR PI73184, how do I share a CICS Transaction Server for z/OS (CICS TS) V5.1 CICS System Definition (CSD) file with a CICS TS V4.2 or earlier region or a V5.1 regions without the PTFs applied?

PI60388 provides system autoinstall capability for Language Environment (LE) program definitions. PI73184 just reships DFHCURDM with the PTF ++HOLD ACTION for UI42619 and UI42620 indicating you must run a DFHCSDUP UPGRADE USING(DFHCURDM) to implement the new Program.

Answer

If running CICS TS V5.1 and you have applied UI43662 and UI42619 and have completed your CSD upgrade and you are sharing the 5.1 CSD with lower level CICS releases you need to be aware of the following:

  • The CSD upgrade will remove group CEE from the list DFHLIST, it does not delete the contents of the CEE group from the CSD.

  • For CICS TS V5.1 regions the CEE group is not required because CICS will autoinstall the LE definitions.

  • For CICS TS V4.2 or earlier (and CICS TS V5.1 regions without the PTFs applied) the CEE group needs to be added to the list of groups installed in the same way as CICS-supplied compatibility groups are applied to lower level regions.

Posted on behalf of Mark Todd
IBM CICS Level3 Support

[{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSGMGV","label":"CICS Transaction Server"},"Platform":[{"code":"PF035","label":"z\/OS"}],"Component":"Maintenance","Version":"5.1"}]

Product Synonym

CICS/TS CICSTS CICS TS CICS Transaction Server

Document Information

Modified date:
02 August 2017

UID

dwa1386336