IBM Support

EIBRESP=16 EIBRESP2=107 from EXEC CICS INVOKE WEBSERVICE

Troubleshooting


Problem

An EXEC CICS INVOKE WEBSERVICE or EXEC CICS INVOKE SERVICE command in a new requestor type webservice application returns EIBRESP 16 and EIBRESP2 107 in CICS Transaction Server for z/OS (CICS TS).

Symptom

After using CETR to turn on CICS auxtrace with components EI(1-2), AP(1-2), PI(1-2), SO(1-2), and WB(1-2), the programmer ran the transaction. As a result, you see an exception trace entry:

 PI 0601 PIIW EXIT  - FUNCTION(INVOKE_WEBSERVICE) RESPONSE(EXCEPTION)
 REASON(UNEXPECTED_NORESP) SOAP_FAULT_RESP1(3) SOAP_FAULT_RESP2(6B)

So, CICS Transaction Server for z/OS (CICS TS) appears to consider the XML to be non-SOAP compliant and is making a "NORESP" (no response) claim. But there was definitely a response, as evidenced by the contents of DFHRESPONSE.

Cause

The SOAP_FAULT_RESP1(3) SOAP_FAULT_RESP2(6B) is usually caused by an invalid MEDIATYPE in the soap response received from the server.

Trace shows:

 WB 0701 WBCL  EXIT - FUNCTION(READ_RESPONSE) RESPONSE(OK) 
 SET_BUFFER(00000000 , 000000000 , 00000100) MEDIATYPE(application/xml)
 CHARSET(UTF-8)

The trace eyecatcher shows:

 *....application/xml
 *
 *    UTF-8
 *    ....Unsupported Media Type

Resolving The Problem

For SOAP 1.1: MEDIATYPE must be text/xml

For SOAP 1.2: MEDIATYPE must be application/soap+xml

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB70","label":"Z TPS"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSGMGV","label":"CICS Transaction Server"},"ARM Category":[{"code":"a8m0z00000007gPAAQ","label":"Web Services"}],"ARM Case Number":"","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"5.4.0;5.5.0;5.6.0;6.1.0;6.2.0"}]

Product Synonym

CICS/TS CICSTS CICS TS CICS Transaction Server

Document Information

Modified date:
05 January 2026

UID

dwa1410774