IBM Support

NullPointerException when connecting to CICS IA Collector after upgrading IA plug-in

Question & Answer


Question

Why would I receive the following message when trying to connect to the IA Collector after upgrading from CICS Interdependcy Analyzer (CICS IA) plugin V5.3.5 to V5.3.7 or V5.3.6 for CICS Explorer:

 Couldn't connect. No response from the host received. (200) OK  
 <hostname>:<portnumber>

Here is the Exception Stack Trace:

 java.lang.NullPointerException
  at com.ibm.cics.ia.commands.WebServiceRequest.createGroupElement
 (WebServiceRequest.java:522)
  at com.ibm.cics.ia.commands.WebServiceRequest.
 createAtomContentWithGroupElement(WebServiceRequest.java:438)
  at com.ibm.cics.ia.commands.WebServiceRequest.run(WebServiceRequest.
 java:175)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

I have another instance of z/OS Explorer that has V5.3.5 of the CICS IA plugin installed. I can connect successfully to the IA Collector with this version of the software.

I did encounter this problem when I upgraded the CICS IA plugin from V5.3.5 to V5.3.6 in late February.

Answer

The web service description (WSDL) was updated on the server to support changes in the CICS IA plugin. The plugin at the 5.3.0.6 or later levels requires the host side APAR PI74028 (PTF UI44728). See PI74028 and IV92215.

[{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSPPUS","label":"CICS Interdependency Analyzer for z\/OS"},"Platform":[{"code":"PF035","label":"z\/OS"}],"Component":"CICS Explorer","Version":"","Line of Business":{"code":"LOB17","label":"Mainframe TPS"}},{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSGMGV","label":"CICS Transaction Server"},"Platform":[{"code":"PF035","label":"z\/OS"}],"Line of Business":{"code":"LOB17","label":"Mainframe TPS"}}]

Product Synonym

CICSIA CICS IA;CICS/TS CICSTS CICS TS CICS Transaction Server

Document Information

Modified date:
17 May 2017

UID

dwa1374843