Troubleshooting
Problem
When upgrading ICN from 2.0.3.5 or 2.0.3.6 to ICN 3.0.6 or later, the preview action and thumbnails do not work for some documents.
The following error displays in the UI when the preview action is used:
CIWEB1059: The document cannot be converted into a viewable format.
The document might have been deleted, the repository server might not be running, or the viewer cannot convert the selected document.
Close the viewer, refresh the list of documents, and try to open the document again.
If the problem persists, contact your system administrator with the following information:
java.io.IOException: java.util.concurrent.ExecutionException:
com.ibm.mm.viewer.CMBDocumentEngineException:My Document was not recognized as a supported format.
Cause
ICN 2.0.3.5 and 2.0.3.6 have a license file, SnowboundLicense.xml, in the navigator.war/WEB-INF/classes directory. This license file was moved to a JAR file in the ICN 2.0.3.7 release, but the file is not removed during an ICN upgrade.
The presence of the old license file in the navigator.war/WEB-INF/classes directory can cause the preview action and viewing thumbnails to fail.
Resolving The Problem
Remove the SnowboundLicense.xml file from navigator.war/WEB-INF/classes, or uninstall and reinstall ICN.
Document Location
Worldwide
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Document Information
Modified date:
23 March 2020
UID
ibm16113362