IBM Support

Readme and Release notes for release 5.4.0.1 Engineering and Scientific Subroutine Library 5.4.0.1 ESSL-5.4.0.1-ppc64LE-Linux Readme

Fix Readme


Abstract

xxx

Content

Readme file for: ESSL-5.4.0.1-ppc64LE-Linux
Product/Component Release: 5.4.0.1
Update Name: ESSL-5.4.0.1-ppc64LE-Linux
Fix ID: ESSL-5.4.0.1-ppc64LE-Linux
Publication Date: 6 January 2017
Last modified date: 6 January 2017

Installation information

Download location

Below is a list of components, platforms, and file names that apply to this Readme file.

Fix Download for Linux

Product/Component Name: Platform: Fix:
Engineering and Scientific Subroutine Library Linux PPC64LE RHEL
Linux PPC64LE SLES
ESSL-5.4.0.1-ppc64LE-Linux

Prerequisites and co-requisites

None

Installation information

  • - Installing the RPMs

    This package contains optional ESSL runtime RPMs. It is not required that you install all of the runtime RPMs but you must upgrade any RPM that is already installed.

    These installation instructions do not cover the following scenarios. For information on these scenarios, please refer to the ESSL for Linux on POWER, Version 5 Release 4 Installation Guide.
    1. Manual acceptance of the ESSL License
    2. Install ESSL using xCAT Kits

    This package may be installed in one of two ways:
    1. As an upgrade to an existing install of ESSL 5.4.0
    2. As a new install of ESSL 5.4.0


    How to Upgrade an existing install of ESSL 5.4.0.
    1. Copy the tar file to a directory with write access and change to that directory
      cd < tarDirectory >
    2. Extract the files and executable from the tar file with the following command:
      tar -xzvf ESSL-5.4.0.1-ppc64LE-Linux.tar.gz
    3. Issue RPM commands for the RPMs you wish to upgrade
      rpm -Uvh essl.3264.rte-5.4.0-1.ppc64le.rpm
      rpm -Uvh essl.3264.rtecuda-5.4.0-1.ppc64le.rpm
      rpm -Uvh essl.6464.rte-5.4.0-1.ppc64le.rpm


    How to Install ESSL 5.4.0 including this upgrade using automatic license acceptance.
    For manual acceptance of the license, please refer to the ESSL for Linux on POWER, Version 5 Release 4 Installation Guide and install ESSL 5.4.0-0 before installing this upgrade.
    1. Copy the tar file to a directory with write access and change to that directory
      cd < tarDirectory >
    2. Extract the files and executable from the tar file with the following command:
      tar -xzvf ESSL-5.4.0.1-ppc64LE-Linux.tar.gz
    3. Copy the RPMs to the directory which contains all the ESSL 5.4.0 RPMs that you wish to install. See "Determining which product RPMs to install" section of the ESSL for Linux on POWER, Version 5 Release 4 Installation Guide for information on which RPMs are required and which are optional
    4. cd to the directory with the RPMs
    5. export IBM_ESSL_LICENSE_ACCEPT=yes
    6. rpm -Uvh essl*5.4.0-*.rpm


    Note: If the ESSL product is not installed in the default directory of /opt/ibmmath, then you must specify the directory using the --prefix parameter on the "rpm -Uvh" command.

      Example:
      rpm -Uvh essl.3264.rte-5.4.0-1.ppc64le.rpm --prefix=essl_path


    For additional information, refer to the ESSL for Linux on POWER, Version 5 Release 4 Installation Guide.

Additional information

  • - Description

    ESSL performs computations using high-performance algorithms.

    ESSL provides these run-time libraries:

  • - Package Information

    The updates contained in the tar file available for download from the corrective service site provide corrective fixes for ESSL for Linux on POWER, Version 5.4.0.

    Update to Version
    Update from Version

    Update (tar file) contents

    APAR changes included:

[{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSFHY8","label":"Engineering and Scientific Subroutine Library"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]

Document Information

Modified date:
06 January 2017

UID

isg400003072