Troubleshooting
Problem
When trying to import from a file in i2 Analyst's Notebook, after the import file is selected, the following error is displayed in a pop-up: "An error occurred while opening the specification. Data at the root level is invalid. Line 1, position 1." After clicking on "OK" Analyst's Notebook will terminate.
Cause
From i2 Analyst's Notebook, when an import is initiated, the previously used import specification file is inspected as a match for the import. The error "An error occurred while opening the specification" is generated if there is a problem with the import specification file or if it could not be accessed. Possible additional details include the following:
- "Data at the root level is invalid. Line 1, position 1."
Contents of the specification file is corrupted and does not contain the expected xml data. - "Root element is missing"
Specification file is empty - "Unexpected end of file has occurred. The following elements are not closed: ImportSpecification. Line 3, position1."
Specification file is truncated. - "Could not find a part of the path 'x:\My_Import_Specifications\Test.ximp'"
The Import specification file could not be found or accessed.
After you receive this error, and click on "OK" to close the pop-up, Analyst's Notebook will terminate.
Resolving The Problem
To resolve the issue so you can continue to work without the error/crash, you will need to stop Analyst's Notebook from accessing the bad specification file. Change the values of the Import Specifications Workgroup and/or Local folders to prevent Analyst's Notebook from locating the bad import specification file. After you rename the bad file or resolve the access issue, you can point the Workgroup and/or Local folders back to the original location. This will not resolve the cause of the bad Import Specification File, but it will allow you to resume working in Analyst's Notebook.
- Open the Importer Pane. Select Import -> Importer Pane :

- In the Importer Pane, select "Saved Specifications..." to launch the Import Specifications window. Under "Other Tasks" on the left, click "Change Workgroup Folder" and/or "Change Local Folder" to change the values. You should now be able to do your imports without a crash.

If your error was that you could not find the path, check your access to the Workgroup Folder as well as the Local Folder. Make sure you can read and write to files from these locations.
Historical Number
TS000880798
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg22016176