IBM Support

Available patches for SPSS Modeler on IBM Cloud Pak for Data

Preventive Service Planning


Abstract

This document lists the available patches for the SPSS Modeler service on IBM Cloud Pak for Data.

Content

cpd-3.0.2-spss-modeler-patch-2

Patch name cpd-3.0.2-spss-modeler-patch-2
Released on 22 January 2021
Service assembly spss-modeler
Applies to service version SPSS Modeler 3.0.2
Applies to platform version Cloud Pak for Data 3.0.1
Patch type Cumulative
Description This patch includes:
  • Fixes for minor security issues.
  • Fix for the issue of preview failing on a Data Asset node that connects to Postgres 12.3. Note that if you use PostgreSQL, you'll have SQL pushback capability. With Generic JDBC there is not SQL pushback. (21792)
Instructions See Applying patches.

cpd-3.0.2-spss-modeler-patch-1

Patch name cpd-3.0.2-spss-modeler-patch-1
Released on 9 December 2020
Service assembly spss-modeler
Applies to service version SPSS Modeler 3.0.2
Applies to platform version Cloud Pak for Data 3.0.1
Patch type Cumulative
Description This patch includes:
  • An upgrade from Python 3.6 to Python 3.7. Due to this security update, note that some models that were build using SPSS Modeler in Watson Studio Cloud prior to this upgrade can no longer be deployed using Watson Machine Learning. If you're using one of the following 6 notes in an SPSS Modeler flow, you must rebuild and redeploy your model(s):
    - XGBoost Tree
    - XGBoost Linear
    - One-Class SVM
    - HDBSCAN
    - KDE Modeling
    - Gaussian Mixture
  • An updated SPSS Modeler runtime (18.2)
  • Fixes for several issues such as:
    - Navigation menu changes after saving a model and returning to Project (8668)
    - Data Audit images not showing up in output table (8845)
    - Unable to create new data asset using export node (8837)
    - Nugget not generated from Text Mining node's Interactive Workbench (8814)
    - Running a Text Link Analysis node fails with "unable to perform last action" (8812)
    - SPSS Modeler not writing data to correct path (8534)
    - New data exported from Data Asset Export node doesn't exist in Project assets (8813)
Instructions See Applying patches.

spss-modeler 3.0.2

Red Hat announced that Red Hat OpenShift Container Platform Version 4.3 will be out of support on 22 October 2020.

Starting 1 September 2020, Cloud Pak for Data is introducing support for Red Hat OpenShift Container Platform Version 4.5 and deprecating support for Red Hat OpenShift Container Platform Version 4.3. A new 3.0.2 version of the spss-modeler service assembly is available.

If you already installed Cloud Pak for Data on Red Hat OpenShift Container Platform Version 4.3, work with your IBM Support representative to migrate to Red Hat OpenShift Container Platform Version 4.5. Note that you must install the new 3.0.2 version of the spss-modeler assembly before upgrading to OpenShift Container Platform 4.5.

If you are ready to install Cloud Pak for Data Version 3.0.1 on Red Hat OpenShift Container Platform 4.5, ensure that you install the 3.0.2 version of the spss-modeler service and other appropriate versions of Cloud Pak for Data services on your cluster.

For more information, see the Cloud Pak for Data documentation.

cpd-3.0.1-spss-modeler-patch-2

Patch name cpd-3.0.1-spss-modeler-patch-2
Released on 31 July 2020
Service assembly spss-modeler
Applies to service version SPSS Modeler 3.0.1
Applies to platform version Cloud Pak for Data 3.0.1
Patch type Cumulative
Description This patch includes:
  • Fix for data preview not working on Data Asset nodes when assets were imported from the catalog
  • New flow properties such as time zone and date and time format.
  • Fixes for security issues.
  • Support for x86 and Power
Instructions See Applying patches.
 

cpd-3.0.1-spss-modeler-patch-1

Patch name cpd-3.0.1-spss-modeler-patch-1
Released on 30 June 2020
Service assembly spss-modeler
Applies to service version SPSS Modeler 3.0.1
Applies to platform version Cloud Pak for Data 3.0.1
Patch type Cumulative
Description This patch fixes:
  • A security issue in jackson-databind library (CVE-2017-7525, CVE-2017-17485, CVE-2018-5968). This fix is for x86 only (the issue doesn't exist on POWER).
  • A security issue removing kernel-headers (CVE-2017-11473, CVE-2017-12190, CVE-2017-12192, CVE-2017-15129,  CVE-2017-15306, CVE-2020-12888, CVE-2018-1000004, CVE-2017-1000410, CVE-2017-1000255, CVE-2017-17449 CVE-2017-17448)
Instructions See Applying patches.
 
This document will be updated each time a patch is released.

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSHGYS","label":"IBM Cloud Pak for Data"},"Component":"SPSS Modeler","Platform":[{"code":"PF040","label":"RedHat OpenShift"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
22 January 2021

UID

ibm15693678