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QRadar: QRadar Deployment Intelligence (QDI) アプリケーションの CPU の正常性メトリックが欠落している

Troubleshooting


Problem

QRadar Deployment Intelligence (QDI) を使用することで、管理者はデプロイメントの正常性をモニターし、特定のメトリックを視覚化することができます。しかしながら、QRadar 7.2.8 および 7.3.0 では、CPU グラフにデータが表示されません。本 Technoteでは CPU メトリックを有効にする方法についてご案内します。

Cause

これは QDI アプリケーションの障害ではありません。QRadar 7.2.8 および 7.3.0 の環境では CPU メトリックの定義が無いことに関連しています。この問題は QRadar 7.3.1 の将来のリリースにおいて解決されます。QRadar 7.2.8 または 7.3.0 を持つ管理者がすべてのアプライアンスから CPU メトリックを収集するためには、デプロイメント内のすべての QRadar 管理対象ホストにて関連付けられた sql ファイルを実行する必要があります。


この問題が発生すると、QRadar 7.2.8 及び 7.3.0 には QDI が収集するためのメトリックの定義が無いため、 CPU 使用率メトリックには N/A が表示されます。本 Technote に添付された sql ファイルを使用することで QDI はこのデータを表示することができます。

図 1: 修正を適用した後の CPU 使用率のイメージ例。値が表示されるまでには数分かかる場合があります。

Resolving The Problem

始める前に
この手順は IBM App Exchange から入手可能な 7.2.6 及び 7.2.8 以上のバージョンの QDI で機能します。また、分散デプロイメント内のすべてのプライマリー・アプライアンスで実行する必要があります。 HA ペアを使用している管理者の場合は、ファイルがプライマリー・ホストからセカンダリー・ホストに複製されるため、スタンバイ状態のセカンダリー・アプライアンスでユーティリティーの実行は必要ありません。

: この手順は QRadar 7.3.1 を使用している場合は必要がありません。

手順

  1. 本手順に添付された QDI_CPU_metrics_delta.sql スクリプトをダウンロードします。
    QDI_CPU_metrics_delta.sql
    md5sum 831f99c9977adba63a4887bacc67228d
  2. WinSCP や同等のツールを使用して、コンソールの /tmp ディレクトリーにファイルを移動させます。
  3. QRadar コンソールに root ユーザーでログインします。
  4. ファイルの整合性を検証するために。以下のコマンドを入力して sql ファイルの MD5 値と比較します。
    md5sum QDI_CPU_metrics_delta.sql
  5. 次のコマンドを使用してデプロイメントのすべてのアプライアンスにスクリプトをコピーします。
    /opt/qradar/support/all_servers.sh -p /tmp/QDI_CPU_metrics_delta.sql | tee QDI_transfer.log
  6. 欠落している CPU メトリックの定義をインポートするために、次のコマンドをコンソールで実行して CPU の正常性メトリックの定義をインストールします。
    /opt/qradar/support/all_servers.sh -C "psql -U qradar -a -f /tmp/QDI_CPU_metrics_delta.sql" | tee QDI_update.log
    : トラブルシューティングが必要な場合は、管理者はこの手順における両方の QDI ログ・ファイルを参照する必要があります。スクリプト再実行によって問題が発生しなかった場合、ログ・ファイルの出力が上書きされます。そのため、トラブルシューティングを目的として手順を再度実行する場合にはログの名前を変更することを推奨します。
  7. QRadar ユーザー・インターフェイスから QDI タブを更新します。

結果

CPU の正常性メトリックのデータが QRadar デプロイメントのアプライアンスの QDI アプリケーションで使用可能になります。 QDI アプリケーションでデータが表示されるようになるまでには数分かかる場合があります。 CPU メトリックが表示されない場合は、ブラウザー・キャッシュを削除し、 QRadar に再度ログインすることを推奨します。本手順や本問題について質問がある場合は、 QRadar フォーラムでお問い合わせください。 QRadar Deployment Intelligence アプリケーションの質問は、フォーラムの QDI タブを使用してフィルタリングすることができます。

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Document Information

Modified date:
31 May 2020

UID

ibm15692538