IBM Support

Unable to search a shipment in Sterling Store Web for an order with PersonInfoMarkFor at order header level

Troubleshooting


Problem

Attempts to search a shipment with PersonInfoMarkFor at order header leveldoes not return any results in IBM Sterling Store Web.

Symptom

Steps to reproduce:
 

  1. Create 2 orders from Sterling Order Management.

    a) PersonInfoMarkFor at order header level

    <Order DocumentType="0001" DraftOrderFlag="N" EnterpriseCode="DEFAULT" SellerOrganizationCode="DEFAULT" >
    <PersonInfoMarkFor FirstName="sa" LastName="sa" EMailID="sa@sa.com"/>
    <OrderLines>
      <OrderLine ShipNode="Nod1" OrderedQty="1" PrimeLineNo="1" SubLineNo="1">
        <Item ItemID="Itm1" UnitOfMeasure="EACH"/>
      </OrderLine>
    </OrderLines>
    <PersonInfoBillTo Country="US" ZipCode="12345"/>
    <PersonInfoShipTo Country="US" ZipCode="12345"/>
    </Order>


    b) PersonInfoMarkFor at order line level

    <Order DocumentType="0001" DraftOrderFlag="N" EnterpriseCode="DEFAULT" SellerOrganizationCode="DEFAULT" >
    <OrderLines>
      <OrderLine ShipNode="Nod1" OrderedQty="1" PrimeLineNo="1" SubLineNo="1">
        <Item ItemID="Itm1" UnitOfMeasure="EACH"/>
        <PersonInfoMarkFor FirstName="sa" LastName="sa" EMailID="sa@sa.com"/>
      </OrderLine>
    </OrderLines>
    <PersonInfoBillTo Country="US" ZipCode="12345"/>
    <PersonInfoShipTo Country="US" ZipCode="12345"/>
    </Order>

     
  2. Schedule, Release & create a shipment for both orders.

     
  3. Order Status: Included In Shipment. Shipment Status: Ready For Backroom Pick.


     
  4. Login to Web Store. In (Customer Pickup/Backroom Pick) widget, click on Advanced Search link.


In Customer Information section:
- CHECK the Is pickup recipient checkbox.
- In Recipient first name textbox, input text: sa. Click Search button.

Actual Result: 
In Shipment Search Results:
- Shipment created for an order with PersonInfoMarkFor at order header level doesn't appear.
- Shipment created for an order with PersonInfoMarkFor at order line level appears.

Cause

This is Working as Designed.

Diagnosing The Problem

An order is created with 'PersonInfoMarkFor' at the order header level. Post schedule, release a shipment is created for it to be picked from web store. In Shipment Search screen, while searching a shipment through 'personInfoMarkFor' address - no search result appear.

However if an order is created with 'PersonInfoMarkFor' at the order line level & related shipment is searched through personInfoMarkFor address - it appears in the search result.

Resolving The Problem

Shipment can have lines from different orders and hence personInfoMarkFor specified at the order header level does not work. Also personInfoMarkFor passed at the order header level is not automatically copied to the order line level.

So PersonInfoMarkFor must be passed at the order line level while creating the order.

[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management System Software"},"ARM Category":[{"code":"a8m0z000000cy00AAA","label":"Orders"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.0.0;9.0.0;9.1.0;9.2.0;9.2.1;9.3.0;9.4.0;9.5.0"}]

Document Information

Modified date:
25 October 2025

UID

swg22005919