IBM Support

Unable to access certain websites after updating the XGS appliance.

Troubleshooting


Problem

After the IBM QRadar Network Security (XGS) appliances were upgraded, some websites either become inaccessible or require lengthy connection time.

Cause

After a firmware update, the Certificate Authority (CA) trusted list is also updated, and some expired or insecure CAs are removed.
If a website is signed by the CA that has been removed from the trusted list, it would become inaccessible or require longer loading time during SSL Inspection on the client.

Diagnosing The Problem

In the System Events, an error event indicates "unable to get local issuer certificate" or "self signed certificate in certificate chain."

When the option "Block connection if server certificate is invalid" is enabled in Outbound SSL Inspection Settings, XGS will validate the CA certificate provide by the server.
If the CA issued by the web site is not listed in Trusted Certificate Authorities for outbound SSL, it will not be able to establish the connection.

Resolving The Problem

To resolve the problem, you must install the CA of the web server into the Trusted Certificate Authorities to allow XGS to trust the certificate issued by the web server:
  1. Retrieve the CA certificate of the web server.
  2. From the appliance Local Management Interface (LMI), click Manage System Settings > Network Settings > Outbound SSL Inspection Settings.
  3. Click the Trusted Certificate Authorities tab.
  4. Click New to input the certificate, or click Upload to upload the certificate file.

Note: Two insecure CA certificates issued by VeriSign have been removed from the latest XGS firmware update. For more information, visit:
https://knowledge.symantec.com/support/ssl-certificates-support/index?page=content&id=ALERT1941
 

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Document Information

Modified date:
24 January 2021

UID

swg22005572