Troubleshooting
Problem
Attempts to install a plugin using IBM Content Navigator results in the error "A connection to the web client cannot be established by using the following URL:."
Symptom
No error is written to the Content Navigator debug level SystemOut.log
Cause
The plugin jar file is present in multiple directories. One of which is a directory defined in the application server's JVM CLASSPATH. This causes the plugin jar to be loaded during the application server startup. If the plugin classes are present at the JVM level it will be loaded by the Java classloader. This prevents Content Navigator from being able to install the plugin because it is unable to access the child classloader to find and load the com.ibm.ecm.extension.Plugin in the WEB-INF/classes directory.
Environment
ICN 2.0.3.x
Diagnosing The Problem
Open the ICN desktop with additional logging enabled using the following URL:
< your server>:<port>/navigator/?desktop=<desktop>&useConsole=false&logLevel=7
A console log window will appear and it should provide more information as to why the plugin installation is failing. In some cases, the logging URL will allow the plugin to install, but it will not work. If so, restart the application server and check its system log. In this case, it is ClassLoader NoClassDefFoundError:
[6/28/17 9:55:12:395 EDT] 0000013c SystemOut O CIWEB Error: [administrator(unknown) @ <your system>] [REQUEST 1] com.ibm.ecm.util.PluginUtil.loadPlugins() Exception loading plug-in c:\your plugin.jar
java.lang.NoClassDefFoundError: com.ibm.ecm.extension.Plugin
at java.lang.ClassLoader.defineClassImpl(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:331)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:155)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:712)
at java.net.URLClassLoader.access$400(URLClassLoader.java:93)
at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:1164)
at java.security.AccessController.doPrivileged(AccessController.java:488)
at java.net.URLClassLoader.findClass(URLClassLoader.java:595)
Caused by: java.lang.ClassNotFoundException: com.ibm.ecm.extension.Plugin
Resolving The Problem
1. Remove the duplicate instances of the plugin jar file from the file system. There should only be one instance of the file in a directory that is not in the application server classpath.
2. Stop the application server JVM and clear its cache directories.
3. Start the server and try installing the plugin again.
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg22005474