IBM Support

Required system packages for ClearCase version 9.0.1 and later on Linux x86_64 hosts

Question & Answer


Question

What system library packages are needed to run IBM Rational ClearCase version 9.0.1.x and later on Linux x86_64 hosts?

Answer

The ClearCase version 9.0.1 and later releases on Linux x86_64 hosts are 64-bit applications that require the following 64-bit packages.
Red Hat:
  • glibc
    libICE
    libSM
    libX11
    libXext
    libXp (only for 9.0.1, not required for 9.0.1.1 and later)
    libXt
    libacl
    libgcc
    libstdc++
    ncurses-libs
    openmotif (2.3)

SUSE:
  • glibc
    libacl
    libgcc_s1
    libncurses5
    libstdc++6
    openmotif-libs (2.3)
    xorg-x11-libICE
    xorg-x11-libSM
    xorg-x11-libX11
    xorg-x11-libXext
    xorg-x11-libXp (only for 9.0.1, not required for 9.0.1.1 and later)
    xorg-x11-libXt

Ubuntu:
  • libacl1:amd64
    libc6:amd64
    libgcc1:amd64
    libice6:amd64
    libmrm4:amd64
    libncurses5:amd64
    libsm6:amd64
    libstdc++6:amd64
    libx11-6:amd64
    libxext6:amd64
    libxm4:amd64
    libxp6:amd64 (only for 9.0.1, not required for 9.0.1.1 and later; see note below)
    libxt6:amd64
  • Note: In release 9.0.1, ClearCase UNIX/Linux native GUIs require the libXp library, which is not available on Ubuntu 16.04. That library is available on Ubuntu 14.04, which you can install using the following commands:

    $ cd /tmp
    $ wget https://mirrors.kernel.org/ubuntu/pool/main/libx/libxp/libxp6_1.0.2-1ubuntu1_amd64.deb
    $ sudo dpkg --install libxp6_1.0.2-1ubuntu1_amd64.deb


    In release 9.0.1.1 and later, libXp is not required.

32-bit compatibility libraries

In addition to the 64-bit applications, there are some 32-bit applications included with ClearCase on the linux_x86_64 platform. These applications are only used if you have view server databases formatted for ClearCase version 8.0.1 or earlier. This would typically occur if you uninstall the ClearCase version 8.0.1 linux_x86 release that you had installed on a 64-bit Linux x86_64 host using 32-bit compatibility mode, then install the ClearCase 9.0.1 linux_x86_64 release. In this case, any view server databases stored on the host would need reformatting.

To reformat old view server databases, your system needs the following 32-bit packages plus their dependencies:
Red Hat:
  • glibc.i686
    libacl.i686
    libgcc.i686
    ncurses-libs.i686

SUSE:
  • glibc-32bit
    libacl-32bit
    libgcc_s1-32bit
    libncurses5-32bit

Ubuntu:
  • libacl1:i386
    libc6:i386
    libgcc1:i386
    libncurses5:i386

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Component":"Not Applicable","Platform":[{"code":"PF016","label":"Linux"}],"Version":"9.0.1.x;9.0.1","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"GUI: xclearcase","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
11 March 2019

UID

swg22003747