IBM Support

Hardware and Software Requirements: Data Protection for VMware V8.1.2

Preventive Service Planning


Abstract

This document details the hardware and software requirements for IBM® Spectrum Protect™ for Virtual Environments: Data Protection for VMware V8.1.2.

Content

The Data Protection for VMware requirements vary by high level functional component. Data Protection for VMware has the following high level functional components:

  • Data Protection for VMware vSphere GUI
  • Data mover
  • Recovery agent
  • Mount proxy

Note:
  • All Data Protection for VMware functional components must be at the same fix pack level. Within a given fix pack level, the interim fix level can differ.

    Examples:
    • When upgrading the Data Protection for VMware vSphere GUI, all other functional components (data movers, recovery agents, and mount proxy nodes) must be also upgraded to the same fix pack level.
    • When upgrading a data mover from 8.1.2.x to 8.1.2.y (where x<y), it is not required that all other functional components be upgraded to 8.1.2.y (but they all must be at the same fix pack level).

This document is divided into linked sections for ease of navigation. You may use the links to jump to the section of the document that you want.

Software requirements for Data Protection for VMware
Additional software requirements

Support and limitations

Hardware requirements for Data Protection for VMware

Where to download IBM Spectrum Protect for Virtual Environments 8.1.2

Hardware and Software requirements for other releases of Data Protection for VMware


Software requirements for Data Protection for VMware

    Supported VMware vSphere versions

    The following VMware vSphere versions are supported:
    • vSphere 5.5 and 5.5 update and patch levels (See "Important considerations for vSphere 5.5" below)
    • vSphere 6.0 and 6.0 update and patch levels
    • vSphere 6.5 and 6.5 update and patch levels (See "Important considerations for vSphere 6.5" below)
    Attention: VMware KB 2090639 describes a critical VMware Changed Block Tracking (CBT) integrity issue that can lead to unrestorable backups of VMs on ESXi 5.5 hosts. To avoid this issue, upgrade ESXi 5.5 hosts to Patch 4 or a later patch or update level.

    Important considerations for vSphere 5.5
    • Version 8.1.2 of the IBM Spectrum Protect vSphere Client plug-in does not support vSphere 5.5. You must use plug-in version 8.1.0 or earlier with vSphere 5.5.

    Important considerations for vSphere 6.5
    • Virtual Machines using the new VMware vSphere 6.5 Virtual Machine encryption are not supported
    • Folder objects in the vSphere Web Client do not have a Configure Tab in vSphere 6.5.0

    Note:
    • Backup management tagging, requires VMware vCenter 6.0 Update 1 or later update or patch level.
    • To view supported vSphere and ESXi host versions, refer to the following technote: "IBM Spectrum Protect™ for Virtual Environments: Data Protection for VMware data mover compatibility guide with VMware's Virtual Disk Development Kit"
      http://www.ibm.com/support/docview.wss?uid=swg21672351


    Data Protection for VMware vSphere GUI

    This functional component integrates the product with the VMware vSphere client in order to back up, restore, and manage virtual machines in the VMware vCenter and includes the Data Protection for VMware command-line interface.

    Note:
    • To enable file restore capability, the Data Protection for VMware vSphere GUI must be installed on a Windows system.
    • To enable file restore for a Linux® virtual machine, in addition to installing Data Protection for VMware on a Windows system, a Linux mount proxy system must also be configured.
    Note:For the Data Protection for VMware vSphere GUI to function correctly with tagging support, ensure that at least one data mover is installed on the same system as the Data Protection for VMware vSphere GUI.

    Attention: Connection to the vCenter Server is required to install the Data Protection for VMware vSphere GUI. If your vCenter Server uses an RSA key with an encryption length greater than 2048 bits, then before installing the Data Protection for VMware vSphere GUI, you must download and install the unrestricted JCE policy files. The instructions are in the technote Installing the Data Protection for VMware vSphere GUI: Download unrestricted SDK JCE files. You do not need to install these files if your RSA key encryption length is 2048 bits or less.

    The supported operating systems by platform are listed in Operating systems support overview tables


    Data mover

    The data mover enables:
    • off-host block level incremental backups
    • application protection for VM guests

    The VMware Virtual Disk Development Kit (VDDK) version 6.0.3 runtime files are used for backing up virtual machines by the data mover. The data mover supports the following operating systems, as long as they are also supported by the VDDK version 6.0.3. For updates on supported operating systems and known issues and limitations regarding the VDDK 6.0.3 see the VDDK release notes web page.

    The data mover utilizes the VDDK APIs to open, close, read, and write virtual machine disk (VMDK) data. To determine the level of VDDK used in each level of Data Protection for VMware, as well as compatible ESX/ESXi builds supported by the VDDK level, please refer to the technote:


    "IBM Spectrum Protect for Virtual Environments: Data Protection for VMware data mover compatibility guide with VMware's Virtual Disk Development Kit" located here http://www.ibm.com/support/docview.wss?uid=swg21672351

    For details about the supported applications and required licensed software programs to perform database or mailbox level restore operations with application protection for VM guests - see Support and limitations.

    The supported operating systems by platform are listed in Operating systems support overview tables


    Mount proxy

    A mount proxy represents the Linux or Windows system that provides access to virtual machine disks backup or persistent snapshots. Mount proxy systems are required when using the Data Protection for VMware vSphere GUI Mount wizard and when using the file restore portal.

    When accessing a Windows virtual machine, a Windows mount proxy system is required. A Windows and Linux mount proxy pair is required when mounting a Linux virtual machine.

    For a Linux or Windows mount proxy system, the following applications must be installed and configured:
    • IBM Spectrum Protect data mover Version 8.1.2.


    The following operations requires:
    • File restore operations from persisted snapshots on the local hardware storage (local backups) the VDDK is required on the mount proxy system
    • Mount or file restore operations from server backups iSCSI connection is required.

    • For a Windows mount proxy system, the following applications must be additional installed and configured:
      • IBM Spectrum Protect for Virtual Environments recovery agent Version 8.1.2

      Note:
      • For a windows mount proxy, the iSCSI Initiator service must be running during the virtual machine disk mount operation and the file restore operation. By default, the iSCSI service is started manually. If the system where this service is running restarts, the iSCSI service must be restarted manually.
      • For a Linux mount proxy, the iSCSI service must be configured and running during the VMDK mount operation and the file restore operation. By default, the iSCSI service is started manually. If the system where this service is running restarts, the iSCSI service must be restarted manually.

    The supported operating systems by platform are listed in Operating systems support overview tables


    Recovery agent

    This service enables the mounting of any snapshot volume from the IBM Spectrum Protect server. You can view the snapshot locally, with read-only access, on the client system, or use iSCSI protocol to access the snapshot from a remote computer. In addition, the recovery agent provides the instant restore function. A volume used in instant restore processing remains available while the restore process proceeds in the background. The recovery agent is accessed with the recovery agent GUI or command-line interface.

    The supported operating systems by platform are listed in Operating systems support overview tables


    Operating systems support overview tables
    Operating systems support tables for all 8.1.2 Data Protection for VMware functional components:

    Operating Systems
    Data Mover*
    GUI
    Mount Proxy**
    Recovery Agent

    Linux x86_x64
    Red Hat Enterprise Linux (RHEL) 6(E2)(SL1)(4)(E1)(E2)(SL1)(2)
    Red Hat Enterprise Linux (RHEL) 7(E2)(4)(E1)(E2)(3)
    SUSE Enterprise Linux (SLES ) 11(E3)(SL2)(5)(E1)(E3)(SL2)
    SUSE Enterprise Linux (SLES ) 12(E3)(5)(E1)(E3)

    *The operating systems listed in the Data Mover column, are supported as long as they are also supported by the VDDK v6.0.3. For updates on supported operating systems and known issues and limitations regarding the VDDK 6.0.3 see the VDDK release notes web page.

    **The VMware Virtual Disk Development Kit (VDDK) version 6.0.3 runtime files are used for local backups functionality by the mount proxy. To be able to use this functionality the mount proxy supports the following operating systems, as long as they are also supported by the VDDK version 6.0.3. For updates on supported operating systems and known issues and limitations regarding the VDDK 6.0.3, see the VDDK release notes web page.

    (E1) Server Edition only
    (E2) Client and Server Editions
    (E3) Desktop and Server Editions

    (SL1) RHEL 6.6 and later maintenance levels and mod levels
    (SL2) SLES 11SP3 and later maintenance levels and mod levels

    (2) RHEL 6.6 requires the Red Hat lvm2 bug fix update 1171805 for the lvm2 component in version lvm2-2.02.117-1.el6. See https://rhn.redhat.com/errata/RHBA-2015-1470.html

    (3)The following RHEL 7.0 issue addressed with https://bugzilla.linux.ibm.com/show_bug.cgi?id=123449 is solved with RHEL 7.1. For that reason Mount proxy support starts with RHEL 7.1.

    (4) To perform backups or restores of VMware virtual machines the libfuse.so2, libxml2.so, and libexpat.so shared object libraries must be installed on Red Hat Enterprise Linux system. Install fuse-libs version 2 package. Some distributions may not have these installed.

    (5) To perform backups or restores of VMware virtual machines the libfuse.so.2 shared object library must be installed on a SUSE Linux system. Install the libfuse version 2 package. Some distributions may not have these installed.



    Operating Systems
    Data Mover*
    GUI
    Mount Proxy
    Recovery Agent

    Windows x64
    Windows 8.1(E5)
    Windows 10 (E5)
    Windows Server 2012(E4)(E4)(1)(E4)(E4)(1)
    Windows Server 2012 R2(E4)(E4)(E4)(E4)

    *The operating systems listed in the Data Mover column, are supported as long as they are also supported by the VDDK v6.0.3. For updates on supported operating systems and known issues and limitations regarding the VDDK 6.0.3 see the VDDK release notes web page.

    (E4) Essentials, Standard, and Datacenter Editions
    (E5) Professional and Enterprise Editions

    (1) This functional component provides support for Windows Storage Server 2012 for functionality that is also available and supported by this functional component on the Windows Server 2012 Editions.


    Indicates that the operating system version is not supported by this Data Protection for VMware functional component.
    Indicates that the operating system version is supported by this Data Protection for VMware functional component. Later maintenance and modification levels to the operating system version are also supported.

Additional software requirements

The following additional software is required to use Data Protection for VMware:
  • Tivoli Storage Manager (TSM) Server 7.1 and later interim fixes and fix packs
  • IBM Spectrum Protect Server 8.1 and later interim fixes and fix packs

Support and limitations

Data Protection for VMware components support the following applications:
  • The following browsers are supported with Data Protection for VMware

  • - Microsoft Internet Explorer version 11 on Windows
    - Google Chrome 50 or later on Windows and Linux
    - Mozilla Firefox 45 Extended Service Release or later on Windows and Linux
  • Application protection for VM guests


  • Application protection supports the following 64-bit applications for the Windows x64 platform for granular restore:
    - Microsoft Exchange Server 2013 CU2 and later CU and maintenance levels: Standard or Enterprise Editions
    - Microsoft Exchange Server 2016 and maintenance levels: Standard or Enterprise Editions

    - Microsoft SQL Server 2014 and later maintenance levels: Standard. Business Intelligence, or Enterprise Editions
    - Microsoft SQL Server 2016 and later maintenance levels: Standard, Business Intelligence, or Enterprise Editions

    Application protection is supported on the data mover for the operating systems listed in Operating systems support overview tables

    Note: The data mover, which enables application protection backups, is only supported on Windows with 64-bit guest operating systems.

    Application protection requires at least one of the following separately licensed software programs to perform individual database or mailbox level restore operations:

    For Microsoft Exchange Server:
    - IBM Spectrum Protect for Mail 8.1.2
    - IBM Spectrum Protect for Mail 7.1.6

    For Microsoft SQL Server:
    - IBM Spectrum Protect for Databases 8.1.2
    - IBM Spectrum Protect for Databases 7.1.6



Hardware requirements for Data Protection for VMware

Hardware requirements vary and depend on the following items:
- Number of protected servers
- Number of protected volumes
- Data set sizes
- LAN and SAN connectivity

The following tables describe the hardware requirements that are needed to install Data Protection for VMware.

Component Minimal requirement Preferred
System Intel Pentium D dual coreIntel Pentium D eight core
Memory 2 GB RAM, 2 GB virtual address space8 GB RAM, 8 GB virtual address space
Available hard disk200 MB2 GB
Network1 GbE10 GbE



Where to download IBM Spectrum Protect for Virtual Environments 8.1.2

The IBM Spectrum Protect for Virtual Environments download document provides information about how and where to obtain the IBM Spectrum Protect for Virtual Environments 8.1.2 package. The information is located at: http://www.ibm.com/support/docview.wss?uid=swg24043700




Hardware and Software requirements for other releases of Data Protection for VMware

The hardware and software requirements for other releases and fix packs for all IBM Spectrum Protect Data Protection for Virtual Environment components are located in the "IBM Spectrum Protect for Virtual Environments - All Requirements Doc" located at:
http://www.ibm.com/support/docview.wss?uid=swg21505139

[{"Product":{"code":"SSERB6","label":"IBM Spectrum Protect for Virtual Environments"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"Data Protection for VMware","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.1.2","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg22003622