IBM Support

Commerce on Cloud failed to lock the STAGLOG table

Troubleshooting


Problem

Stage propagation fails during dailyJob execution with following error: Failed to lock the STAGLOG table.

Symptom

Stage propagation fails during dailyJob execution with following error:

20170419-203219| <Error> The command failed to lock the STAGLOG table.
<SQLException> DB2 SQL Error: SQLCODE=-911, SQLSTATE=40001,
SQLERRMC=68, DRIVER=4.19.49
SQLState: 40001
Vendor Error Code: -911
Stack trace:
com.ibm.db2.jcc.am.SqlTransactionRollbackException: DB2 SQL Error:
SQLCODE=-911, SQLSTATE=40001, SQLERRMC=68, DRIVER=4.19.49

Cause

The following error is thrown when the staging propagation task is unable to obtain an exclusive lock to the STAGLOG table:

The command failed to lock the STAGLOG table.

The error is thrown when another task holds row locks or table lock, usually because content was being edited on the server at the time when the staging propagation task ran - for example, a dataload job was executed by a human user.

Resolving The Problem

STAGLOG records will be processed on the next successful execution of the dailyJob. Do not update content during the next dailyJob execution to increase its chances of completing the staging propagation task successfully.

[{"Product":{"code":"SSWT7D","label":"Commerce on Cloud"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB31","label":"WCE Watson Marketing and Commerce"}}]

Document Information

Modified date:
16 June 2018

UID

swg22002379