Troubleshooting
Problem
403 Forbidden Message appear when user first time to set up for Cognos optional gateway with IIS server and accessing Cognos Analytics via gateway url
Symptom
HTTP 403 forbidden with no Icon for Team content or Report in Cognos Analytics
Cause
IIS Application User for Cognos Analytics does not have full permission to access Cognos Analytics folder and files
Environment
window
Resolving The Problem
Ensure the application pool has file system access to Cognos Analytics folder
Example: ca, application pool name.
1. Open window explorer for properties of Cognos Analytics installation location
2. Select Security tab and Edit for user name
3. Add application name "ca"
From this location: Server location
Enter the object name to select: IIS APPPOOL\ca
4. Add "ca" user name and provide permissions for ca as "Full control"
Example: ca, application pool name.
1. Open window explorer for properties of Cognos Analytics installation location
2. Select Security tab and Edit for user name
3. Add application name "ca"
From this location: Server location
Enter the object name to select: IIS APPPOOL\ca
4. Add "ca" user name and provide permissions for ca as "Full control"
[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
27 November 2023
UID
swg22002090