Question & Answer
Question
Why does IBM Call Center for Commerce display Out of stock for items with inventory/inventory Alerts?
Cause
Out of stock display lead to confusion on item availability.
Answer
CCC is expected to show Global Availability of item in Distribution Group (DG) for shipping delivery method. Thus application expects to read availability for Item from Default Distribution Group and not individual nodes.
Node Level RTAM does not update DISTRIBUTION_RULE_ID and ORGANIZATION_CODE columns in the YFS_INVENTORY_ALERTS table as one node node can belong to multiple Distribution Groups.
Consequently, when Distribution Group level alert is not populated for the Item, it is expected to show out of stock, however this will not stop flow execution.
- If you want to show availability for item while taking order, Alerts have to be populated to default DG.
- If you do not expect to show Out of Stock and don't want to populate alerts, then you can hide the Label.
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Document Information
Modified date:
16 June 2018
UID
swg21993146