IBM Support

Call Center for Commerce is displaying Out of stock for items with inventory

Question & Answer


Question

Why does IBM Call Center for Commerce display Out of stock for items with inventory/inventory Alerts?

Cause

Out of stock display lead to confusion on item availability.

Answer

CCC is expected to show Global Availability of item in Distribution Group (DG) for shipping delivery method. Thus application expects to read availability for Item from Default Distribution Group and not individual nodes.

Node Level RTAM does not update DISTRIBUTION_RULE_ID and ORGANIZATION_CODE columns in the YFS_INVENTORY_ALERTS table as one node node can belong to multiple Distribution Groups.

Consequently, when Distribution Group level alert is not populated for the Item, it is expected to show out of stock, however this will not stop flow execution.

  • If you want to show availability for item while taking order, Alerts have to be populated to default DG.

  • If you do not expect to show Out of Stock and don't want to populate alerts, then you can hide the Label.

[{"Product":{"code":"SSYLSL","label":"IBM Call Center for Commerce"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF003","label":"Android"},{"code":"PF010","label":"HP-UX"},{"code":"PF014","label":"iOS"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF034","label":"Windows Mobile"}],"Version":"9.5;9.4;9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21993146