IBM Support

QRadar: Services are restarting in the middle of the night

Question & Answer


Question

Why are services including the GUI restarting overnight?

Cause

The default settings for Auto Update is at 3 AM in any time zone. If Auto Deploy has been checked then QRadar will deploy changes which will restart required services. If Auto Restart has been checked, then all services including Tomcat will restart resulting in loss of the User Interface.

Answer

The best alternative is to set Auto Updates to happen during a nightly maintenance window. If 3 AM is not a good time for changes to occur, then you can change the time using this procedure.

  1. Log in to the QRadar User Interface.
  2. Click the Admin tab > Auto Update icon > Change Settings.
  3. Adjust the Auto Update Schedule.
  4. Click Save.

If you require Scheduled Maintenance period for these changes to Occur.

Note: Changes to DSMs, Scanners, QVM, QIDs, and other Updates, will not take effect until you have deployed changes. Protocol updates require the Tomcat service to be restarted.

Procedure to resolve Auto Update restarting services.
  1. Log in to the QRadar User Interface.
  2. Click the Admin tab > Auto Update icon > Change Settings.
  3. Scroll to bottom of Update Configuration.
  4. Uncheck Auto Restart Service.
  5. Uncheck Auto Deploy.
  6. Click Save.


For more information on Auto Update setting please refer to this link:
Configuring automatic update settings



Where do you find more information?

[{"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Admin Console","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21991390