IBM Support

How to install the Citrix client - for IBM's Controller on Cloud

Question & Answer


Question

Customer is using IBM's Controller on Cloud product. What does the end user need to do, to connect?

Cause

Controller-on-Cloud is powered by Citrix, therefore the end user must install a Citrix client onto their PC.

Answer

Method #1 (Recommended)
The following method will install the latest Citrix client, and is therefore recommended:
1. It is not necessary for the end user to be a Windows administrator on their PC/laptop.
  • However, in some circumstances it can make things easier. Therefore, in some (rare) circumstances you may need to ask your I.T. department to (temporarily) make you a Windows administrator (on your PC/laptop).
2. Launch the Citrix Workspace (client) download website, for your operating system.
TIP: At the time of writing, here are the correct websites:
  • Windows (English):  https://www.citrix.com/en-gb/downloads/workspace-app/windows/
  • All other operating systems/versions: https://www.citrix.com/en-gb/downloads/workspace-app/
 
3. Click on the button "Download Citrix Workspace app for Windows"
image 2865
4. After the file (typically "CitrixWorkspaceApp.exe") has downloaded, double click on it

image 2867

5. Click 'Start':

image 5357

6. Tick 'I Accept' to the license agreement, then click Next:

image 5358

7. For most customers, it is best if they do NOT tick "Enable app protection":

image 5359

8. Click "Install"

9. At the end, click "Finish":

image 2868

10. Test by launching the Controller-on-Cloud website, and type in your username and password:


 
18. To launch the program, click on the 'Cognos Controller' icon:

image 5360

19. After a few seconds, you may get this message:

image 5361

You MUST do the following (otherwise you will not be able to read/write from/to files on your PC/laptop later):

  • Tick box 'Do not ask me again for this site'.
  • Then click on "Permit all access"

=================================================

Method #2
This method uses the IBM Cloud website, but will install an older version of the Citrix client.
1. Launch the Controller-on-Cloud website
  • This is a unique website (separate for each customer)
 

2. Tick the box 'I agree with the Citrix license agreement'


 
3. Click 'Install'
 
4. When prompted, click "Run":

 
5. Click 'Start'

 
6. Tick 'I Accept'

 
7. Click 'Next'
 
8. Do NOT tick 'Enable single sign-on'

9. Click 'Next'
 
10. Decide whether-or-not to send data to Citrix (in this example, I chose 'No')

11. Click 'Install'
 
12. Click 'Finish' afterwards.
 
13. Click 'Allow' when prompted:

 
14. Click 'Run Control' when prompted:

 
15. Tick "Do not show me the warning for this program again":

 
16. Click 'Allow'
 
17. Type in your username and password:

 
18. To launch the program, click on the 'Cognos Controller' icon:

19. Soon after opening Controller, you may want to read/write files from/to your PC's local hard drive

  • For example, you may want to open an Excel link report (XLSX file) from your laptop's C: drive.
  

When you attempt to do this, you will receive the following screen:

 

Choose "Permit all access"

Tick box 'Do not ask me again for this site'.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMRTZ","label":"IBM Cognos Controller on Cloud"},"ARM Category":[{"code":"a8m0z000000brHTAAY","label":"Citrix"}],"ARM Case Number":"TS004009010","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
12 October 2021

UID

swg21990028