IBM Support

'Invalid XSL format (or) file name' error when running the dtxsupport.bat file

Troubleshooting


Problem

If directed by IBM Support to run the dtxsupport.bat batch script to collect support information, and you see the following: C:\IBM\WebSphere Transformation Extender 8.4.1>dtxsupport.bat Invalid XSL format (or) file name. The syntax of the command is incorrect.

Symptom

C:\IBM\WebSphere Transformation Extender 8.4.1>dtxsupport.bat
Invalid XSL format (or) file name.
The syntax of the command is incorrect.

Cause

This is due to a bug in the Microsoft wmic implementation on the Windows operating system, where the locale being used in anything other than 'US English'.

Resolving The Problem

Edit line 576 of dtx_ui.bat file and apply the following change to resolve the problem.

From:

for /f "skip=2 tokens=2-7 delims=," %%a in ('wmic Path Win32_LocalTime Get Day^,Hour^,Minute^,Month^,Second^,Year /Format:CSV') do (

To:

for /f "skip=2 tokens=2-7 delims=," %%a in ('wmic Path Win32_LocalTime Get Day^,Hour^,Minute^,Month^,Second^,Year /Format:"%WINDIR%\System32\wbem\en-us\csv"') do (

[{"Product":{"code":"SSVSD8","label":"IBM Transformation Extender"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.0;8.4.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
29 September 2018

UID

swg21977645