IBM Support

Postmaster NPS does not start

Troubleshooting


Problem

nzstart: Error: unexpected error accessing system catalog: Lock file "/nz/data.1.0/postmaster.pid" already exists. Is another postgres (pid 28427) running in "/nz/data.1.0"?

Symptom

NPS will not restart.

Cause

This is usually caused when a former postmaster process has kept a lock in /tmp/postmaster.pid file
or when it is still present as a defunct pid.

Environment

All Pure Data Appliances

Diagnosing The Problem

Please follow the next action plan

--Make sure that NPS is stopped

nzstate

--if not

nzstop

Resolving The Problem



ps -ef | grep -i postmaster


kill -9 <pid>


--restart NPS

nzstart

[{"Product":{"code":"SSULQD","label":"IBM PureData System"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Administration","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 October 2019

UID

swg21962523