Troubleshooting
Problem
A Tivoli Storage Manger Server installation fails to install DB2. The db2_install.log file logs error DBI1288E.
Symptom
The Tivoli Storage Manager Server installation in console mode reports that the installation of DB2 failed with the following message :
ANRI1020E: The DB2 installation failed. To review errors and correct any issues, review /var/ibm/InstallationManager/logs/native/tsm_logs/db2_install.log.
Cause
The umask is not set correctly or the /opt mountpoint is mounted with nosuid
Diagnosing The Problem
Review the db2_install.log file. in this case, the following error was logged :
ERROR: DBI1288E The execution of the program /opt/tivoli/tsm/db2 failed.
This program failed because you do not have write permission on the directory or file .
Review the permission of the db2 install directrory. For example :
ls -al /opt/tivoli/tsm/db2
drwxrwxrwx. 3 root root 4096 Jun 25 16:12 .
drwx------. 3 root root 4096 Aug 15 2014 ..
drwx------. 3 root root 4096 Aug 15 2014 client
Review the output of the umask system command. For example :
# umask
077
Resolving The Problem
Follow the steps below to resolve this issue.
- Set the umask to "022" in the shell running the installation using the umask command. For example :
umask 022
Note that the umask may also be set globally in the '/etc/profile' file. - Make sure that /opt is not mounted with nosuid.
- Re-run the installation after removing the /opt/tivoli/tsm directory.
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21961672