IBM Support

Requiring recompilation of SIP applications migrated from WebSphere 7.0 or below to WebSphere 7 With CEA feature pack or WebSphere 8.0 and above.

Troubleshooting


Problem

Using a SIP application migrated from WebSphere 7.0 or below to WebSphere 7 With CEA feature pack or WebSphere 8.0 and above may result in an exception

Symptom

Calling javax.servlet.sip.URI.clone() may result in an java.lang.IllegalAccessError

Cause

As a result of an Oracle Security-in-Depth Fix,
SIP applications that were compiled against WebSphere 7, or SIP Servlets 1.0 interfaces (older standard) and are used with newer WebSphere versions WebSphere 7.0 with CEA feature pack or WebSphere 8.0 and above, may throw an java.lang.IllegalAccessError while calling the javax.servlet.sip.URI.clone() function.

Resolving The Problem

The solution for this issue is to compile the application again with the Sip interface from the newer version with a minimum version of WebSphere 7.0 with CEA feature pack or WebSphere 8.0 and above

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"SIP Container\/SIP Proxy Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF012","label":"IBM i"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"8.5.5.4","Edition":"Advanced;Base;Developer;Enterprise;Express;Feature Pack for CEA;Network Deployment","Line of Business":{"code":"LOB15","label":"Integration"}}]

Document Information

Modified date:
15 June 2018

UID

swg21691389