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ODBC client connections dropping intermittently with error 'Communication link failure'

Troubleshooting


Problem

ODBC client connections dropping intermittently with error 'Communication link failure'

Symptom

If ODBC debug logging is enabled the following similar error message will show in the log:

[2014-09-29 23:40:04.0663 Cen] [5696] [6076] Socket Error: Function = 'Sock_read', Line = 478, State = '08S01', number = 14, Msg = 'Communication link failure'

Cause

External agents (firewall, network management software etc) could be terminating an idle client/server connection.

Environment

IBM PureData System for Analytics with any Netezza Platform Software (NPS) release

Diagnosing The Problem

Take a network trace (tcpdump) to monitor network traffic and identify the agent that is closing the connection.

Enable ODBC debug logging.

Resolving The Problem

The recommendation in case of communication failure caused by an external agent (firewall, network management software etc) is to reduce the tcp_keepidle to an interval that is less than that enforced by such agents.

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Product Synonym

Netezza PDA Appliance

Document Information

Modified date:
17 October 2019

UID

swg21689126