IBM Support

ERROR: Some or all RPMs failed to install - PureData System for Analytics

Troubleshooting


Problem

RPM installation takes too much time and is aborted during an NPS upgrade.

Symptom

NPS Upgrade fails with the following error messages:

    ERROR: RPM installation took too much time and was aborted.
    (Inaccesible partitions or NFS shares)
    ERROR: Some or all RPMs failed to install: nzhwinfo-1.1-noarch.rpm

    ERROR: NPS software upgrade failed! Cleaning up...

    ERROR: NPS software upgrade failed! Resolve the issues and retry.

Affected RPM may vary. May encounter following error message variation:
    ERROR: Some or all RPMs failed to install: OpenIPMI-tools-2.0.6-11.el5.x86_64.rpm

Cause

NFS mounts enabled during NPS upgrade

Diagnosing The Problem

1 - Run df -k and verify if it hangs due to NFS mounts

2 - Cat /etc/fstab and check if entry for NFS mount is present.


Resolving The Problem

Need to deactivate NFS mounts on both hosts prior to NPS upgrade in order to avoid this behavior:

1 - Edit /etc/fstab using vi and comment /nfsdir entry by adding # at the beginning of the line
2 - Unmount NFS directory: umount -l /nfsdir
3 - Reattempt NPS upgrade: /nz/kit.version/sbin/nzupgrade upgrade

[{"Product":{"code":"SSULQD","label":"IBM PureData System"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"System Upgrade","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 October 2019

UID

swg21676019