Troubleshooting
Problem
Mailbox restore might fail with MAPI_E_FAILONEPROVIDER, even if the security requirements for Individual Mailbox Restore are met.
Symptom
Although all the security requirements for Individual Mailbox Restore are met, both, the restore of any mailbox and also the test with 'tdpmapi testmapi', fails with error MAPI_E_FAILONEPROVIDER.
Cause
A CAS-Array, defined as object in the Active Directory, might point to the wrong CAS Server or LoadBalancer.
Environment
The usage of a CAS Server is new for Exchange Server 2010 and has changed with Exchange Server 2013 again. Here the function of CAS-Array is omitted without replacement.
Diagnosing The Problem
The security requirements for Individual Mailbox Restore are:
Data Protection for Exchange must be operating in an account with membership in the Organization Management group.
The account must have a live Exchange mailbox in the domain.
The Microsoft Exchange Server MAPI Client and Collaboration Data Objects (MAPI) requires a connection to a CAS-Server, in case the local Exchange Server does not have the CAS role configured, in order to get access to the individual mailbox. So, the CAS-server is acting as a mailbox-server.
MAPI_E_NETWORK_ERROR will be returned, if no CAS Server can be found.
MAPI_E_FAILONEPROVIDER will be returned, if a CAS Server can be found, but either the account, in which the MAPI operates for the Individual Mailbox Restore has insufficient authorization or it has no active mailbox in this domain.
The CAS Server can be located with the Exchange PowerShell command:
>get-ExchangeServer | Format-Table Name,ServerRole
Make sure, the ">TDPMAPI TESTMAPI /excserver=.." command returns successfully, if the proper CAS Server, found by the above command, is specified with option '/excserver='.
In case the ">TDPMAPI TESTMAPI /excserver=.." command always returns MAPI_E_FAILONEPROVIDER, even though the CAS Server is specified by:
- server name
- IP name
- IP address
then the request might be re-routed by CAS-Array entry in the Active Directory.
Resolving The Problem
Running the MFCMAPI test tool from Microsoft and following the directions, given in the blog:
http://blogs.msdn.com/b/pepeedu/archive/2010/09/12/how-to-access-system-mailbox-in-exchange-2010-using-mfcmapi.aspx
will exclude Tivoli Storage Manager for Mail: Data Protection for Exchange as possible reason for this issue.
Adding the CAS Server IP address to the C:\Windows\System32\drivers\etc\hosts file will prevent the rerouting to a different CAS server or LoadBalancer by the CAS-Array definition in the Active Directory.
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Document Information
Modified date:
17 June 2018
UID
swg21672157