IBM Support

Database connection errors out with SQL0901N, reason "Scan interface error".

Troubleshooting


Problem

Attempt to connect to a database errors out with the following message: SQL0901N The SQL statement or command failed because of a database system error. (Reason "Scan interface error".) SQLSTATE=58004

Symptom

db2diag.log may contain messages similar to the following:


2014-05-03-15.05.53.162851-240 E18009E500 LEVEL: Event
PID : 28711 TID : 140498656290560 PROC : db2sysc 0
INSTANCE: db2inst1 NODE : 000 DB : FOO
APPHDL : 0-9 APPID: *LOCAL.db2inst1.140503190552
AUTHID : DB2INST1 HOSTNAME: hostname
EDUID : 289 EDUNAME: db2agent (FOO) 0
FUNCTION: DB2 UDB, base sys utilities, sqeLocalDatabase::FirstConnect, probe:1000
START : DATABASE: FOO : ACTIVATED: NO

2014-05-03-15.05.53.175509-240 I18510E567 LEVEL: Severe
PID : 28711 TID : 140498656290560 PROC : db2sysc 0
INSTANCE: db2inst1 NODE : 000 DB : FOO
APPHDL : 0-9 APPID: *LOCAL.db2inst1.140503190552
AUTHID : DB2INST1 HOSTNAME: hostname
EDUID : 289 EDUNAME: db2agent (FOO) 0
FUNCTION: DB2 UDB, catalog services, sqlrlGetVersionTimes, probe:180
MESSAGE : Database release: 10010300 ==> Database is now moved back to the
current DB2 release level of 10010000

2014-05-03-15.05.53.177067-240 I19078E533 LEVEL: Severe
PID : 28711 TID : 140498656290560 PROC : db2sysc 0
INSTANCE: db2inst1 NODE : 000 DB : FOO
APPHDL : 0-9 APPID: *LOCAL.db2inst1.140503190552
AUTHID : DB2INST1 HOSTNAME: hostname
EDUID : 289 EDUNAME: db2agent (FOO) 0
FUNCTION: DB2 UDB, catalog services, sqlrlCatalogScan::insert, probe:20
DATA #1 : String, 14 bytes
Missing column
DATA #2 : String, 17 bytes
VERSIONBUILDLEVEL

2014-05-03-15.05.53.177223-240 I19612E2954 LEVEL: Severe
PID : 28711 TID : 140498656290560 PROC : db2sysc 0
INSTANCE: db2inst1 NODE : 000 DB : FOO
APPHDL : 0-9 APPID: *LOCAL.db2inst1.140503190552
AUTHID : DB2INST1 HOSTNAME: hostname
EDUID : 289 EDUNAME: db2agent (FOO) 0
FUNCTION: DB2 UDB, catalog services, sqlrlCatalogScan::insert, probe:20
DATA #1 : String, 20 bytes
Scan interface error
DATA #2 : String, 0 bytes
Object not dumped: Address: 0x00007FC8751969AC Size: 0 Reason: Zero-length data
DATA #3 : String, 11 bytes
SYSVERSIONS
DATA #4 : String, 11 bytes
INDTABLES01
DATA #5 : Catalog Scan, PD_TYPE_SQLRL_CATALOG_SCAN, 720 bytes
...

Cause

When a database release level and instance level does not match, a -901 error with reason "Scan interface error" is thrown upon an attempt to connect to the database. Likely, db2updvXX would have been run against the database to match the fixpack installed, and it is not possible to use that database on a lower fixpack.

Resolving The Problem

In order for the database to be usable, the instance has to be upgraded to match the database level. In this example, the following message helps to identify which level the instance has to be upgraded to.


MESSAGE : Database release: 10010300 ==> Database is now moved back to the
current DB2 release level of 10010000

A database release level shows v10.1 FP3 but the current instance level is v10.1 GA. In order to get the database working, the instance level has to be upgraded to match the database release level, v10.1 FP3

[{"Product":{"code":"SSEPGG","label":"DB2 for Linux- UNIX and Windows"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Routines (SP & UDF) - SQL","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.7;10.1;10.5","Edition":"Advanced Enterprise Server;Advanced Workgroup Server;Enterprise Server;Workgroup Server","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21672105