Troubleshooting
Problem
When you run Who is hold report in Atlas without using filters, it fails with the following error. "Cannot get a column count" SQL Error #1 Connection has already been closed"
Symptom
Not able to run Who is On Hold Report without using any Filters but other BIRT reports works fine
Cause
The issue happens when you run who is on hold report without filters and happens on Atlas deployed in Weblogic application server.
Environment
Atlas deployed on Weblogic application server.
Diagnosing The Problem
In addition to the error message in the user interface, you will see the following exception in Atlas log(PAearlog.log)
<Forcibly releasing inactive connection
"weblogic.jdbc.wrapper.PoolConnection_oracle_jdbc_driver_T4CConnection@3
0" back into the connection pool "AtlasReportsDS", currently reserved
by: java.lang.Exception
at
weblogic.jdbc.common.internal.ConnectionEnv.setup(ConnectionEnv.java:318
)
This happens because the Weblogic releases connections forcibly assuming it to be inactive
Resolving The Problem
- Login to Weblogic Administration Console.
- Navigate to the JDBC Datasource --> AtlasReportsDS > Connection Pool > Advanced Section.
- Change the Inactive Connection Timeout to 0
- A restart of the application server may be required.
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Document Information
Modified date:
17 June 2018
UID
swg21660209