IBM Support

Server remains in Limited Mode because volumes are write protected

Troubleshooting


Problem

The Tivoli Storage Manager FastBack server remains in Limited Mode because the "FastBack disk write protection feature" denies access to repository volumes.

Symptom

The Tivoli Storage Manager FastBack server entered the Limited Mode and messages similar to the following are logged in the server technical logs (FAST_BACK_SERVERnnn.sf):

[Oct 31 03:14:09:996]( 444)--->E16.HEARTBEAT : HEART_BEAT_S_CollectAlertsInFile: server in limited mode, quit HB.
[Oct 31 03:14:09:996]( 444)--->E14.MGR : MGR_JobScheduler: HEART_BEAT_S_CollectAndSendAlerts failed in limited mode


After following the instructions in the user guide to exit the Limited Mode (see link below), access problems are still logged in the server technical logs (FAST_BACK_SERVERnnn.sf) with messages similar to:


[Oct 31 03:12:18:444]( 678)-->W12.FSI : REP_FSI_S_OpenFileInRepository: failed to open file (open returned -1)
[Oct 31 03:39:25:264]( b88)--->E14.REP : REPLIB_VerifyAccess_LOCAL: disk '\\.\PHYSICALDRIVE0' is write protected. mask [0]
[Oct 31 03:39:25:264]( b88)--->E14.REP : REPLIB_LISTMGR_S_SanityCheck:Repository in c:/programdata/tivoli/tsm/fastback/server/mirror/ can't be accessed
[Oct 31 03:39:25:264]( b88)->I4.GENERAL : CLOG: FBSS7521E The FastBack Server Failed to access Repository in path c:/programdata/tivoli/tsm/fastback/server/mirror/.
[Oct 31 03:39:25:279]( b88)->I4.GENERAL : REPLIB_LISTMGR_S_SanityCheck:return REPLIB_MGR_REP_STATUS_REPOSITORY_MISMATCH
[Oct 31 03:39:25:279]( b88)->I4.GENERAL : CLOG: FBSS7519E The repository sanity check ended. The Repository has a Sanity Problem.


And other unexpected behavior may also occur, like automatic reboot of the server system and missing drive letters for disk volumes.

Cause

Volumes which are used by FastBack are not or no longer excluded from "FastBack disk write protection".

Diagnosing The Problem

Search for the message "disk ... is write protected" in the server technical logs.

Resolving The Problem

Use the DiskOpen utility to either ...
- disable the disk write protection feature if you do not use the FastBack Server SAN mode
or
- re-enable read and write access to all connected disks for FastBack if you use the FastBack Server SAN mode.

Follow the instructions in the user guide for "Allowing read/write access to a disk with disk open utility" (see link below).

[{"Product":{"code":"SS9NU9","label":"Tivoli Storage Manager FastBack"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21655920