IBM Support

IBM Tape device driver retry

Troubleshooting


Problem

Some SAN devices can return a BUSY status when the user attempts to use a tape drive. Issuing a BUSY status is not a regular occurrence for IBM Tape drives, and the device driver does not retry by default.

Symptom

Receiving busy tape drive errors when the drive is not actually busy.

Cause

The SAN to WAN bridges and other devices that slow down SAN traffic might return a BUSY status when Tivoli Storage Manager tries to use the tape drive. The IBM device driver does not try the operation again.

Resolving The Problem

Oracle Solaris driver version 4.0.5.5 or later: Add the entry "max-busy-retry=x" to the IBMtape.conf file, where x is the number of retries. After adding the entry, reload the IBMtape driver or restart the server to activate the change. The default is 0

AIX driver version 12.3.7.0 or later: Run the "chdev -l rmtX -a busy_retry=yes" command for each tape drive or the "chdev -l smcX -a busy_retry=yes" command for the changer.

Windows driver version 6.2.3.7 or later: Add DWORD Value: MAXBusyRetry ( It can be set from 1 to 480)
Under Registry Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ibmtp2kv
Where v is 12 for Windows 2012 or
Where v is 8 for Windows 2008

Linux: No configuration available
HP-UX: No configuration available

The Tivoli Storage Manager device driver does not require any additional settings, and it tries busy responses again by default.

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Document Information

Modified date:
17 June 2018

UID

swg21638275