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ANS1398E errno=13 Permission denied occurs when trying to open dsmerror.log

Troubleshooting


Problem

When performing client operations the following error can occur: ANS1398E Initialization functions cannot open one of the Tivoli Storage Manager logs or a related file: /var/opt/tivoli/tsm/log/dsmerror.log. errno = 13, Permission denied

Symptom

ANS1398E occurs when non-root users perform client operations such as dsmc, dsmadmc, etc.

Cause

If you start dsmadmc or dsmc as non-root, and if ERRORLOGNAME in dsm.sys points to a file that is not writable by non-root users, error message ANS1398E is displayed and the session does not start.

Resolving The Problem

The following steps will resolve this problem:


1. Set the ERRORLOGNAME option in the dsm.sys file.

For example:

ERRORLOGNAME /var/msgs/tsm/dsmerror.log

2. Generate a dsmerror.log by issuing the following:

dsmc q sess

3. Modify the permissions on dsmerror.log to allow writing by all users.

For example, enter chmod 666 /your/path/dsmerror.log.

The following technical document on the backup archive client may also be useful:

http://www-01.ibm.com/support/docview.wss?uid=swg21408654

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21633869